zoukankan      html  css  js  c++  java
  • POJ 1611 -The Suspects (并查集)

    题目

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

    Once a member in a group is a suspect, all members in the group are suspects.

    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4 
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4 
    1
    1

    代码

    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int pre[30010]; 
    int a[30010];
    int find(int x)
    {
        if(pre[x]==x) return x;
        else
        {
            return pre[x]=find(pre[x]);
        }
    }
    void join(int x,int y)
    {
        int fx=find(x),fy=find(y);
        if(fx!=fy) pre[fx]=fy;
    }
    int main()
    {
        int n,m,i,k,ans;
        while(cin>>n>>m)
        {
            if(m==0 && n==0) break;
            for(i=0;i<n;i++)
            pre[i]=i;
            while(m--)
            {
                cin>>k;
                cin>>a[0];
                for(i=1;i<k;i++)
                {
                    cin>>a[i];
                    join(a[0],a[i]);
                }
            }
            ans=0;
            for(i=0;i<n;i++)
            {
                if(find(i)==pre[0]) ans++;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    微信小程序开发入门(十六)
    npm安装教程
    js 比较两个日期大小
    js截取手机号后四位,并倒序输出
    TypeScript的安装和编译
    js中null和" "的区别
    阻止事件冒泡的3种方法
    阻止事件冒泡
    chrome查看js报错Uncaught SyntaxError: Unexpected string
    ES6思维导图
  • 原文地址:https://www.cnblogs.com/cnlik/p/11851872.html
Copyright © 2011-2022 走看看