zoukankan      html  css  js  c++  java
  • D 分组背包

    <span style="color:#3333ff;">/*
    ——————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————
    
    	copyright    :    Grant Yuan
    	time         :    2014.7.18
    	algorithm    :    分组背包
    	
    ————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————
    
    D - 分组背包 基础
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
     
    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
    Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
    N = 0 and M = 0 ends the input.
     
    Output
    For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
     
    Sample Input
    2 2
    1 2
    1 3
    2 2
    2 1
    2 1
    2 3
    3 2 1
    3 2 1
    0 0
     
    Sample Output
    3
    4
    6*/
    #include<cstdio>
    #include<iostream>
    #include<cstdlib>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    int n,m;
    int a[101][101];
    int dp[101];
    
    int main()
    {
    	while(1){
    		cin>>n>>m;
    		if(n==0&&m==0)
    			 break;
    	    for(int i=1;i<=n;i++)
    			for(int j=1;j<=m;j++)
    			  cin>>a[i][j];
    	    memset(dp,0,sizeof(dp));
    
    	    for(int i=1;i<=n;i++)
    			for(int j=m;j>=1;j--)
    			  for(int k=1;k<=j;k++){
    			  dp[j]=max(dp[j],dp[j-k]+a[i][k]);
    			}
    	    cout<<dp[m]<<endl;
    	    }
    	return 0;
    }
    </span>

  • 相关阅读:
    phpspider爬虫框架的使用
    【php设计模式】责任链模式
    【php设计模式】策略模式
    【php设计模式】观察者模式
    【php设计模式】模板模式
    【温故知新】php 魔术方法
    【php设计模式】享元模式
    Java50道经典习题-程序18 乒乓球赛
    Java50道经典习题-程序19 输入行数打印菱形图案
    Java50道经典习题-程序20 求前20项之和
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254498.html
Copyright © 2011-2022 走看看