zoukankan      html  css  js  c++  java
  • 二分PKU3273

    <span style="color:#3333ff;">/*
    F - 二分
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
    
    Status
    Description
    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
    
    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
    
    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
    
    Input
    Line 1: Two space-separated integers: N and M
    Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
    Output
    Line 1: The smallest possible monthly limit Farmer John can afford to live with.
    Sample Input
    7 5
    100
    400
    300
    100
    500
    101
    400
    Sample Output
    500
    Hint
    If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.#include<iostream>
    By Grant Yaun
    2014.7.16
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cstdlib>
    using namespace std;
    int n,m;
    int a[100005];
    int sum;
    int ans;
    int low,high,mid;
    bool can(int k){
      sum=0;int sum1=0;
      for(int i=0;i<n;i++)
         if(a[i]>k)
            return false;
        for(int i=0;i<n;i++)
          {
              if(sum+a[i]<=k){
                sum+=a[i];
                }
              else {
                sum=a[i];
                sum1++;}
          }
          sum1++;
        if(sum1<=m)
          return true;
        return false;
    }
    
    int main()
    {   int max=0;
        while(~scanf("%d%d",&n,&m)){
          for(int i=00;i<n;i++)
            {cin>>a[i];
               max+=a[i];}
            low=0;high=max;
            while(low<=high){  mid=(low+high)*0.5;
              if(can(mid)){
                  high=mid-1;
                  ans=mid;
                }
              else low=mid+1;}
              cout<<ans<<endl;}
              return 0;
    }
    
    </span>


     

  • 相关阅读:
    Prime Time使用
    cache与MMU与总线仲裁
    IUS tcl cmd
    CPU cache
    generated clock
    PL301 matrix内部模块
    014-数据结构-树形结构-基数树、Patricia树、默克尔树、梅克尔帕特里夏树( Merkle Patricia Tree, MPT)
    001-软件架构概览、maven补充【分包工程、合并包、web容器插件】、git补充
    013-数据结构-树形结构-决策树
    012-数据结构-树形结构-哈希树[hashtree]、字典树[trietree]、后缀树
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254513.html
Copyright © 2011-2022 走看看