zoukankan      html  css  js  c++  java
  • (HDOJ 1022)Train Problem I

    Train Problem I
    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     

    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     

    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     

    Sample Input
    3 123 321 
    3 123 312
     

    Sample Output
    Yes. 
    in 
    in 
    in 
    out 
    out 
    out 
    FINISH 
    No. 
    FINISH

     
    Hint
    Hint
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
     

     AC code:

    #include<stdio.h>
    int main()
    {
         
    int n,i,j,k;
         
    char in[10],out[10];
         
    int flag[20];
         
    while(scanf("%d %s %s",&n,in,out)!=EOF)
         {
             
    char stack[1000];
             
    int top=-1;
             i
    =j=k=0;
             
    while(j<n+1&&i<n)
             {
                 
    if(stack[top]==out[i]&&top!=-1)
                 {
                     top
    --;
                     flag[k]
    =0;
                     k
    ++;
                     i
    ++;
                     }
                     
    else
                     {
                         top
    ++;
                         flag[k]
    =1;
                         k
    ++;
                         stack[top]
    =in[j];
                         j
    ++;
                         }
                 }
                 
    if(k!=2*n)
                 printf(
    "No.\n");
                 
    else
                 {
                     printf(
    "Yes.\n");
                     
    for(i=0; i<n*2; i++)
                     {
                         
    if(flag[i])
                         printf(
    "in\n");
                         
    else
                         printf(
    "out\n");
                         }
                    }
                    printf(
    "FINISH\n");
             
            }
            
    return 0;
         

    } 

    作者:cpoint
    本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.
  • 相关阅读:
    均匀分布
    吉布斯采样(Gibbs采样)
    蒙特卡罗方法 Monte Carlo method
    马尔科夫链
    python 3 没有了xrange
    %matplotlib inline的含义
    MCMC采样和M-H采样
    pycharm 安装模块 use the correct version of 'pip' installed for your Python interpreter
    Pycharm安装第三方库时出现Read timed out的解决办法
    如何在Pycharm中添加新的模块(第三方包)
  • 原文地址:https://www.cnblogs.com/cpoint/p/2015315.html
Copyright © 2011-2022 走看看