zoukankan      html  css  js  c++  java
  • dp --- hdu 4939 : Stupid Tower Defense

    Stupid Tower Defense

    Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 1219    Accepted Submission(s): 361


    Problem Description
    FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.

    The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.

    The red tower damage on the enemy x points per second when he passes through the tower.

    The green tower damage on the enemy y points per second after he passes through the tower.

    The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)

    Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.

    FSF now wants to know the maximum damage the enemy can get.
     
    Input
    There are multiply test cases.

    The first line contains an integer T (T<=100), indicates the number of cases.

    Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)
     
    Output
    For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.
     
    Sample Input
    1 2 4 3 2 1
     
    Sample Output
    Case #1: 12
    Hint
    For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
     
    Author
    UESTC
     
    Source
     

    Mean: 

    经典的塔防类游戏。

    敌人要通过一条过道,你有三种塔:红塔---敌人经过该塔时每秒受到x点伤害;  绿塔---敌人经过该塔后,每秒受到y点伤害; 蓝塔---敌人经过该塔后,经过每座塔的时间变慢z秒。现在要你安排这三种塔,使得对敌人的伤害最大。

     

    analyse:

    分析可知,红塔要放到后面。
    然后我们枚举红塔的数量i,对前n-i座塔进行dp。
    dp[i][j]----表示前i座塔中,放j座蓝塔和i-j座绿塔所造成的最大伤害。
    x y z t
    状态转移方程:
    dp[i][j]=max(dp[i-1][j-1]+y*(i-j)*(t+(j-1)*z),dp[i-1][j]+(i-1-j)*y*(t+j*z))

    Time complexity:O(n^2)

    Source code:

    //Memory   Time
    // 18424K   1796MS
    // by : Snarl_jsb
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<iostream>
    #include<vector>
    #include<queue>
    #include<stack>
    #include<string>
    #include<climits>
    #include<cmath>
    #define MAX 1520
    #define LL long long
    using namespace std;
    LL dp[MAX][MAX];
    
    int main()
    {
        LL T,kase=1;
        cin>>T;
        while(T--)
        {
            LL n,x,y,z,t,damage;
            scanf("%I64d %I64d %I64d %I64d %I64d",&n,&x,&y,&z,&t);
            printf("Case #%I64d: ",kase++);
            memset(dp,0,sizeof(dp));
            dp[1][1]=x;
            LL ans=n*x*t;                  //全部放红塔的伤害值
            for(LL i=1;i<=n;i++)          //枚举前i个单位长度
            {
                for(LL j=0;j<=i;j++)     // 枚举前i个单位中蓝塔的数量j
                {
                    if(j==0)
                        dp[i][j]=dp[i-1][j]+y*(i-1)*t;
                    else
                    {
                        LL tmp1=dp[i-1][j-1]+y*(i-j)*(t+z*(j-1));  // 第j座放蓝塔
                        LL tmp2=dp[i-1][j]+y*(i-1-j)*(t+z*j);       // 第j座放绿塔
                        dp[i][j]=max(tmp1,tmp2);
                    }
                    damage=dp[i][j]+(n-i)*x*(t+z*j)+(n-i)*(i-j)*y*(t+z*j);
                    ans=max(ans,damage);
                }
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    [转载]OpenGL函数参考(中文版)
    [转载]OpenGL 中常用的 GLUT 函数库
    VC6.0 VS2008 openGL环境配置 [和glut库的加入]
    java测试一个类的方法,用junit
    openal配置(更新)
    jsp URL 传参数 服务端接收后乱码的问题
    NeHe OpenGL 第二课 学习总结
    vs2008 添加头文件路径
    困惑之一:c++初始化成员列表
    C++中一些对原理描述相当好得语句
  • 原文地址:https://www.cnblogs.com/crazyacking/p/3911872.html
Copyright © 2011-2022 走看看