zoukankan      html  css  js  c++  java
  • poj3254 Corn Fields

    Corn Fields
    Time Limit: 2000MS Memory Limit: 65536K
    Total Submissions: 16473 Accepted: 8678

    Description

    Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

    Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

    Input

    Line 1: Two space-separated integers: M and N 
    Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

    Output

    Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

    Sample Input

    2 3
    1 1 1
    0 1 0

    Sample Output

    9

    Hint

    Number the squares as follows:
    1 2 3
      4  

    There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

    Source

    USACO 2006 November Gold

    题解:这是一道DP状态压缩的入门题,也是我第一次写状态压缩的题,(还好有大佬指导)。这道题最多就只有12行12列,我们就可以每一行用一个二进制数来表示其状态。

    这里重点用到&运算符。

    1.x&(x<<1),用来判断x是否存在相邻的 1,

    2. x&y,用来判断x和y相同的位置上相同的数是否同时为1.

    首先我们可预处理出0~2^n这里面的数那些满足没有相邻的位置同时为1;然后,一个数组将输入的数据转换成二进制数(注意是转换成相反的,即1变成0,0变成1,这样做是为了在x&y为false时,不会存在土地贫瘠且放羊的情况);最后查找每一行满足的情况噢且该行与上一行也不存在相邻位置同时为1的情况;最后求和即可。

    参考代码:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    const int Mod=100000000;
    const int N=13;
    const int M=1<<N;
    int st[M],mp[M];
    int dp[N][M],n,m,x;


    bool judge1(int x)
    {
    return x&(x<<1);
    }


    bool judge2(int x,int y)
    {
    return (mp[x]&st[y]);
    }


    int main()
    {
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    memset(st,0,sizeof st);
    memset(mp,0,sizeof mp);
    memset(dp,0,sizeof dp);
    int num=0;
    for(int i=0;i<(1<<m);i++)
    {
    if(!judge1(i)) st[num++]=i;
    }

    for(int i=1;i<=n;i++)
    {
    for(int j=1;j<=m;j++)
    {
    scanf("%d",&x);
    if(x==0) mp[i]+=(1<<(j-1));
    }
    }

    for(int i=0;i<num;i++)
    {
    if(!judge2(1,i)) dp[1][i]=1;
    }

    for(int i=2;i<=n;i++)
    {
    for(int j=0;j<num;j++)
    {
    if(judge2(i,j)) continue;
    for(int k=0;k<num;k++)
    {
    if(judge2(i-1,k)) continue;
    if(!(st[j]&st[k])) dp[i][j]=(dp[i][j]+dp[i-1][k])%Mod;
    }
    }
    }
    int sum=0;
    for(int i=0;i<num;i++) sum=(sum+dp[n][i])%Mod;
    printf("%d ",sum);
    }
    return 0;
     } 






  • 相关阅读:
    Java web登录验证
    servlet总结
    Hadoop学习笔记(五)之HBASE
    C#学习笔记(二)
    C#学习笔记(一)
    Hadoop学习笔记(五)hdfs的四大机制和两大核心
    Hadoop学习笔记(三)Hadoop的hdfs的原理和运行机制
    Hadoop学习笔记(二)搭建伪分布式和集群模式的环境
    Linux系统常见命令
    python之路--day15--常用模块之logging模块
  • 原文地址:https://www.cnblogs.com/csushl/p/9386541.html
Copyright © 2011-2022 走看看