zoukankan      html  css  js  c++  java
  • hdu-1198

    Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows. 


    Figure 1


    Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

    ADC 
    FJK 
    IHE 

    then the water pipes are distributed like 


    Figure 2


    Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

    Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

    Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show. 
    InputThere are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50. 
    OutputFor each test case, output in one line the least number of wellsprings needed. 
    Sample Input
    2 2
    DK
    HF
    
    3 3
    ADC
    FJK
    IHE
    
    -1 -1
    Sample Output
    2
    3

    题解:

    给你11个田地,随机给你几个,让你计算最少多少块;

    首先对11块打表,然后乐意用DFS或BFS,或并查集(下面为并查集方法),遍历每块的左和上,最后剩下多少块即为最少快数;

    AC代码为:

    #include<iostream>
    #include<cstdio>
    #include<string>
    #include<cstring>
    using namespace std;
    int type[11][4]={1,1,0,0,
        0,1,1,0,
        1,0,0,1,
        0,0,1,1,
        0,1,0,1,
        1,0,1,0,
        1,1,1,0,
        1,1,0,1,
        1,0,1,1,
        0,1,1,1,
        1,1,1,1     
    };


    string str[51];
    int n,m,fa[3300];
     
    void Init(int n)
    {
    for(int i=0;i<n;i++)
    fa[i]=i;
    }


    int Find(int a)
    {
    return a==fa[a]? a:Find(fa[a]);
    }


    void Union(int a,int b)
    {
    int fx=Find(a);
    int fy=Find(b);
    if(fx!=fy)
    fa[fx]=fy;
    }


    int main()
    {
    while(scanf("%d%d",&m,&n))
    {
    if(n<=0 || m<=0)
    break;

    Init(n*m);

    for(int i=0;i<m;i++)
    {
    cin>>str[i];
    }

    for(int i=0;i<m;i++)
    {
    for(int j=0;j<n;j++)
    {
    if(i>0&&type[str[i][j]-'A'][1]==1&&type[str[i-1][j]-'A'][3]==1)
    Union(i*n+j,(i-1)*n+j);
    if(j>0&&type[str[i][j]-'A'][0]==1&&type[str[i][j-1]-'A'][2]==1)
    Union(i*n+j,i*n+j-1);
    }
    }

    int cnt=0;
    for(int i=0;i<n*m;i++)
    {
    if(fa[i]==i)
    cnt++;
    }
    cout<<cnt<<endl;
    }

    return 0;
    }


  • 相关阅读:
    wppay免登录付费查看隐藏内容/付费资源下载
    个人网站html5雪花飘落代码JS特效下载
    HTML5 audio 如何实现播放多个MP3音频
    网站html代码解析
    vue-webpack模板升级到webpack4
    npm安装cnpm
    单个div充满屏幕的CSS方法
    vue监听滚动事件-元素固定位置显示
    HTML5中判断横屏竖屏
    The META for Mobile terminal
  • 原文地址:https://www.cnblogs.com/csushl/p/9386586.html
Copyright © 2011-2022 走看看