zoukankan      html  css  js  c++  java
  • hdu-1114

    Problem Description
    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
     

    Input
    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
     

    Output
    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
     

    Sample Input
    310 11021 130 5010 11021 150 301 6210 320 4
     

    Sample Output
    The minimum amount of money in the piggy-bank is 60.The minimum amount of money in the piggy-bank is 100.

    题解:只是一个完全背包问题;可以转化为普通背包问题;

    dp[j]=min(dp[j],dp[j-w[i]]+value[i]);

    AC代码为:

    #include<bits/stdc++.h>
    using namespace std;
    int dp[1000005];


    int main()
    {
    int T;
    int wa, wb, w;
    int n, val[510], wei[510], i, j;
    scanf("%d", &T);
    while (T--)
    {
    scanf("%d%d", &wa, &wb);
    w = wb - wa;
    scanf("%d", &n);
    for (i = 0; i<n; i++)
    scanf("%d%d", &val[i], &wei[i]);
    fill(dp, dp + 1000005, 10000000);
    dp[0] = 0;
    for (i = 0; i<n; i++)
    {
    for (j = wei[i]; j <= w; j++)
    {
    dp[j] = min(dp[j], dp[j - wei[i]] + val[i]);
    }
    }
    if (dp[w] == 10000000)
    cout << "This is impossible." << endl;
    else
    cout << "The minimum amount of money in the piggy-bank is " << dp[w] << "." << endl;


    }


    return 0;
    }



  • 相关阅读:
    极简风格网络消息以及分发架构
    GPS网络时间服务器是如何让集成系统协调工作的?
    北斗授时设备(NTP时间服务器)对高速联网收费的重要性
    卫星互联网路由技术现状及展望
    【Python】获取中国法定节假日的封装
    GCC 内联汇编基础
    MIT6.828——Lab1 partB(麻省理工操作系统课程实验)
    MIT6.828——Lab1 partA(麻省理工操作系统课程实验)
    bochs(2.6.11)配置安装
    MIT6.828(Step0)——实验环境配置
  • 原文地址:https://www.cnblogs.com/csushl/p/9386587.html
Copyright © 2011-2022 走看看