zoukankan      html  css  js  c++  java
  • HDUOJ 2060 Snooker

    Snooker

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3898    Accepted Submission(s): 1641


    Problem Description
    background:
    Philip likes to play the QQ game of Snooker when he wants a relax, though he was just a little vegetable-bird. Maybe you hadn't played that game yet, no matter, I'll introduce the rule for you first.
    There are 21 object balls on board, including 15 red balls and 6 color balls: yellow, green, brown, blue, pink, black.
    The player should use a white main ball to make the object balls roll into the hole, the sum of the ball's fixed value he made in the hole is the player's score. The player should firstly made a red ball into the hole, after that he gains red-ball's value(1 points), then he gets the chance to make a color ball, then alternately. The color ball should be took out until all the red-ball are in the hole. In other word, if there are only color balls left on board, the player should hit the object balls in this order: yellow(2 point), green(3 point), brown(4 point), blue(5 point), pink(6 point), black(7 point), after the ball being hit into the hole, they are not get out of the hole, after no ball left on board, the game ends, the player who has
    the higher score wins the game. PS: red object balls never get out of the hole.
    I just illustrate the rules that maybe used, if you want to contact more details, visit http://sports.tom.com/snooker/ after
    the contest.

    for example, if there are 12 red balls on board(if there are still red ball left on board, it can be sure that all the color
    balls must be on board either). So suppose Philp can continuesly hit the ball into the hole, he can get the maximun score is
    12 * 1 (12 red-ball in one shoot) + 7 * 12(after hit a red ball, a black ball which was the most valuable ball should be the target) + 2 + 3 + 4 + 5 + 6 + 7(when no red ball left, make all the color ball in hole).
    Now, your task is to judge whether Philip should make the decision to give up when telling you the condition on board(How many object balls still left not in the hole and the other player's score). If Philp still gets the chance to win, just print "Yes", otherwise print "No". (PS: if the max score he could get on board add his current score is equal to the opponent's current score, still output "Yes")
     

    Input
    The first line contains a numble N indicating the total conditions. Then followed by N lines, each line is made of three integers:
    Ball_Left P_Score O_Score represeting the ball number left on board, Philp's current score, and the opponent's current score.
    All the input value are in 32 bit integer value range.
     

    Output
    You should caculate the max score left Philp can gain, and judge whether he has the possiblity to win.
     

    Sample Input
    2 12 1 1 1 30 39
     

    Sample Output
    Yes No
     

    Author
    zl
     
    #include <iostream>
    using namespace std;
    int main()
    {
    	int n,bl,os,ps,flag;
    	cin>>n;
    	while(n--)
    	{
    		flag=0;
    		cin>>bl>>ps>>os;
    		if(ps>=os) flag=1;
    		else
    		{
    			if(bl>=6 && (bl-6)*8+27>=os-ps) flag=1;
    			else
    			{
    				if((15-bl)*bl/2>=os-ps) flag=1;
    			}
    		}
    		printf(flag==1?"Yes\n":"No\n");
    	}
    	return 0;
    }


  • 相关阅读:
    c标签页面进行解析json
    Android 简述touch事件中的MotionEvent
    R中读取文件,找不到路径问题 No such file or directory
    文章标题
    Codeforces Beta Round #2 C. Commentator problem
    openfire 开发遇到的些问题
    BZOJ 刷题记录 PART 5
    公司又裁人了……
    最简单的基于FFmpeg的移动端样例:Android 视频转码器
    单片机: 简易计算器的实现(键盘)
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910534.html
Copyright © 2011-2022 走看看