zoukankan      html  css  js  c++  java
  • The Hardest Problem Ever(字符串处理,易)

    The Hardest Problem Ever

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10638    Accepted Submission(s): 4748


    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
     

    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

    A single data set has 3 components: 

    Start line - A single line, "START" 

    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

    End line - A single line, "END" 

    Following the final data set will be a single line, "ENDOFINPUT".
     

    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.
     

    Sample Input
    START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT
     

    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
     

    Source
     
    #include <stdio.h>
    #include <string.h>
    
    int main()
    {
        int k;
        char str[11], s[500], c;
        char a[] = {'V','W','X','Y','Z','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U' };
        while(scanf("%s%*c", str) && strlen(str) < 6)
        {
            if(str[0] == 'S')
            {
                k = 0;
                //memset(s, '\0', sizeof(s));
                while(c = getchar())
                {
                    //字母
                    if(c >= 'A' && c <= 'Z')  s[k++] = a[c - 'A'];
                    //换行
                    else if(c == '\n')
                    {
                        break;
                    }
                    //除换行、字母以外的包括空格的其他字符
                    else  s[k++] = c;
                }
            }
            else
            {
                s[k] = '\0';
                puts(s);
            }
        }
        return 0;
    }
    


  • 相关阅读:
    linux内核系统调用和标准C库函数的关系分析
    Linux下内存映射文件的用法简介
    Hi35xx 通用GPIO 使用篇(板子3G电源控制脚说明)
    关于Linux用户名
    关于ARGB_8888、ALPHA_8、ARGB_4444、RGB_565的理解
    PixelFormat 图像颜色的数据格式
    Ubuntu 搭建svn服务器 ,以及常见错误解决方案
    安装VisualSVN Server 报错The specified TCP port is occupied
    SVN服务器搭建和使用(三)
    SVN服务器搭建和使用(二)
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910561.html
Copyright © 2011-2022 走看看