zoukankan      html  css  js  c++  java
  • PAT 1007 Maximum Subsequence Sum

    1007 Maximum Subsequence Sum (25 分)
     

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains Knumbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    
    
    int main(){
        int n;
        cin >> n;
        int num[n];
        int flag = 1;
        for(int i=0;i < n;i++) {
            cin >> num[i];
            if(num[i] >= 0)flag = 0;
        }
        if(flag){
            cout << 0<<" " << num[0] <<" "<< num[n-1];
            return 0;
        }
    
    
        int sum = 0;
        int maxsum = 0;
        int j=0,k=0;
        int movej=0;
    
        for(int i=0;i < n;i++){
            sum += num[i];
            if(sum < 0) {sum = 0;movej=i+1;}
            if(maxsum < sum){
                j = movej;k = i;
                maxsum = sum;
            }
        }
        if(num[j] < 0)num[j] = 0;
        if(num[k] < 0)num[k] = 0;
    
        cout << maxsum << " " << num[j] << " " << num[k];
    
    
        return 0;
    }

    看错输出,应该是输出数字的,我输出下标了,还过了2个数据点??

    然后边界条件有个

    3
    -1 -1 0

    应该是输出0 0 0

  • 相关阅读:
    Eclipse中安装Tomcat
    Merge Query
    如何生成Java Key以及sign一个jar
    Create MSSQL Procedure
    MSSQL Procudure Sample
    MSSQL Get Last Monday and Last Sunday
    oracle Data blocks,Extents,Segments
    Oracle Index Clustering Factor(集群因子)
    mapreduce工作原理
    python 实现一个TwoSum的例子
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10680730.html
Copyright © 2011-2022 走看看