zoukankan      html  css  js  c++  java
  • PAT 1035 Password

    1035 Password (20 分)
     

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    

    Sample Input 2:

    1
    team110 abcdefg332
    

    Sample Output 2:

    There is 1 account and no account is modified
    

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    

    Sample Output 3:

    There are 2 accounts and no account is modified
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define maxnum 100005
    
    bool transs(string& s){
        bool flag = true;
        for(int i=0;i < s.size();i++){
            if(s[i] == '1'){s[i] = '@';flag = false;}
            else if(s[i] == '0'){s[i] = '%';flag = false;}
            else if(s[i] == 'l'){s[i] = 'L';flag = false;}
            else if(s[i] == 'O'){s[i] = 'o';flag = false;}
        }
    
        return flag;
    }
    
    
    
    
    
    
    int main(){
        int n;cin >> n;
        vector<vector<string>> vec; //vector不能随便开空间,开了以后就会有默认值,然后你再push-back就加到默认的后面了。
        for(int i=0;i < n;i++){
            string s1,s2;
            cin >> s1 >> s2;
            vector<string>temp;
            temp.push_back(s1);temp.push_back(s2);
            vec.push_back(temp);
        }
        for(int i=0;i < vec.size();i++){ //vector 循环中出现erase要注意i的位置会向前,从而跳过了删除的后一个项
            if(transs(vec[i][1])) {vec.erase(vec.begin()+i);i--;}
        }
        if(vec.size()){
            cout << vec.size() << endl;
            for(int i=0;i < vec.size();i++){
                cout << vec[i][0] << " " << vec[i][1] << endl;
            }
        }
        else{
            if(n == 1) cout << "There is 1 account and no account is modified" << endl;
            else cout << "There are " << n << " accounts and no account is modified";
        }
    
    
        return 0;
    }

    _

    vector不能随便开空间,开了以后就会有默认值,然后你再push-back就加到默认的后面了。
    vector 循环中出现erase要注意i的位置会向前,从而跳过了删除的后一个项
     
  • 相关阅读:
    STL 源代码剖析 算法 stl_numeric.h -- copy
    SQLServer 复制和数据库镜像 具体配置部署
    2016第23周三
    2016第23周二
    2016第23周一
    2016第22周日
    2016第22周六
    2016第22周五
    五个JS经典面试题
    2016第22周三
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10698536.html
Copyright © 2011-2022 走看看