zoukankan      html  css  js  c++  java
  • PAT 1112 Stucked Keyboard

    1112 Stucked Keyboard (20 分)
     

    On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

    Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

    Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line gives a positive integer k (1) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

    Output Specification:

    For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

    Sample Input:

    3
    caseee1__thiiis_iiisss_a_teeeeeest
    

    Sample Output:

    ei
    case1__this_isss_a_teest

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    
    int main(){
        int k;
        cin >> k;
        string s;
        cin >> s;
        unordered_map<char,int> mp;
    
        for(int i=0;i < s.size();i++){
            int cnt = 0;
            for(int j=i;j < s.size() && j < i+k;j++){
                if(s[i] == s[j])cnt++;
            }
            if(cnt == k)mp[s[i]] = 1;
        }
        for(int i=0;i < s.size();){
            int cnt = 0;
            for(int j=i;j < s.size() && j < i+k;j++){
                if(s[i] == s[j])cnt++;
            }
            if(cnt < k){mp[s[i]] = 0;i++;}
            else if(cnt == k) i += k;
        }
    
    
        unordered_map<char,int> mmp = mp;
        for(int i=0;i < s.size();i++){
            if(mmp[s[i]]){
                cout << s[i];
                mmp[s[i]] = 0;
            }
        }
    
        cout << endl;
    
        for(auto it=mp.begin();it!=mp.end();it++){
            if(it->second == 1){
                char x = it->first;
                for(int i=0;i < s.size();i++){
                    if(s[i] == x){s.erase(i,k-1);}
                }
            }
        }
    
        cout << s;
    
    
        return 0;
    }

    _unordered_map 不能保证按修改的顺序输出!需要重新按照顺序输出map中的内容。

    但学会了对拍!!

  • 相关阅读:
    dede织梦编辑器中插入视频文件方法
    织梦在PHP7上安装模块时模块包含的文件为空的解决方法
    织梦dedecms整合添加ckplayer播放器支持flv,mp4等播放功能
    实现dedecms全站动态浏览
    【idea快捷键】
    【Android-stdio-appdemo搭建记录】
    【随记-插件-】
    【mysql远程连库】
    【策略模式和工厂模式的比较】
    【极客学院-idea教程】
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10793070.html
Copyright © 2011-2022 走看看