zoukankan      html  css  js  c++  java
  • PAT 1024 Palindromic Number

    1024 Palindromic Number (25 分)
     

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and Kinstead.

    Sample Input 1:

    67 3
    

    Sample Output 1:

    484
    2
    

    Sample Input 2:

    69 3
    

    Sample Output 2:

    1353
    3
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    #define MAXN 500
    
    string reverstring(string s){
        string res = "";
        for(auto x:s) res = x+res;
        return res;
    }
    
    
    string strplus(string a,string b){
        string res = "";
        int jinwei = 0;
        for(int i=a.size()-1;i>=0;i--){
            int numa = a[i]-'0';
            int numb = b[i]-'0';
            int num = numa+numb+jinwei;
            res = to_string(num%10)+res;
            jinwei = num/10;
        }
        if(jinwei){
            res = "1"+res;
        }
        return res;
    }
    
    
    int main(){
        string s;
        int k;
        cin >> s >> k;
    
    
        int cnt = 0;
        while(cnt!=k){
            string ans = reverstring(s);
            if(s == ans){
                cout << ans << endl << cnt;
                return 0;
            }
            s = strplus(s,ans);
            cnt++;
        }
    
        cout << s << endl << k;
    
    
    
        return 0;
    }

    ez

     
  • 相关阅读:
    08月24日总结
    08月23日总结
    08月22日总结
    装饰器
    卢菲菲最强大脑记忆训练法全套教程 01
    LeetCode 704 二分查找
    LeetCode 1480 一维数组的动态和
    NIO 总结
    LeetCode 881 救生艇
    url的组成部分
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10817720.html
Copyright © 2011-2022 走看看