zoukankan      html  css  js  c++  java
  • LA 3026 Period KMP失配函数的应用

    For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK, that is A concatenated K times, for some string A. Of course, we also want to know the period K.

    Input 

    The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

    Output 

    For each test case, output �Test case #� and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

    Sample Input 

    3
    aaa
    12
    aabaabaabaab
    0
    

    Sample Output 

    Test case #1
    2 2
    3 3
    
    Test case #2
    2 2
    6 2
    9 3
    12 4
    -------------------------------------------------------------------

    如果前i个字符组成一个周期,则循环节为i-f[i]。

    -------------------------------------------------------------------

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    
    using namespace std;
    
    int f[1111111];
    
    void getfail(char* P,int *f)
    {
        int m=strlen(P);
        f[0]=f[1]=0;
        for (int i=1;i<m;i++)
        {
            int j=f[i];
            while (j&&P[i]!=P[j]) j=f[j];
            f[i+1]=(P[i]==P[j])?j+1:0;
        }
    }
    
    void find(char* T,char* P,int* f)
    {
        int n=strlen(T),m=strlen(P);
        getfail(P,f);
        int j=0;
        for (int i=0;i<n;i++)
        {
            while (j&&P[j]!=T[i]) j=f[j];
            if (P[j]==T[i]) j++;
            if (j==m) printf("%d\n",i-m+1);
        }
    }
    
    int main()
    {
        int n;
        char str[1111111];
        int cnt=0;
        while (~scanf("%d",&n))
        {
            if (n==0) break;
            cnt++;
            scanf("%s",str);
            getfail(str,f);
            printf("Test case #%d\n",cnt);
            for (int i=2;i<=n;i++)
            {
                if (f[i]>0&&i%(i-f[i])==0) printf("%d %d\n",i,i/(i-f[i]));
            }
            printf("\n");
        }
        return 0;
    }
    




  • 相关阅读:
    redhat yum ISO 本地源
    md5sum的使用
    查看进程内存使用情况
    常见User-Agent大全
    aggregate和annotate使用
    Django logging配置
    Django 开发调试工具:Django-debug-toolbar
    浏览器的同源策略及跨域解决方案
    Python contenttypes组件
    Dajngo admin
  • 原文地址:https://www.cnblogs.com/cyendra/p/3038414.html
Copyright © 2011-2022 走看看