zoukankan      html  css  js  c++  java
  • NEFU 642 monkey 记忆化搜索

    monkey

    Time Limit 1000ms

    Memory Limit 65536K

    description

     Cc is a lovely monkey. It likes to play the game "catching plates".
        The game is as follows.
        There are n pegs in a line numbered from 1 to n. Cc stands on the first peg at the beginning. It is rather hard for Cc to jump from peg i to peg i+1(i+1<=n) or peg i-1(i-1>=1), which takes him exactly one second. He can jump at most t times. And he will only jump at the beginning of one second.There is a clown at the other end. He has m plates in hand. He will throw a plate to one peg every second. The clown will throw the plate exactly to the peg. The plates will get broken if they hit the pegs. Cc can catch the plate if only he stands on the peg the plate is thrown to. For simplicity, the process of throwing and catching don't take any time at all. Suppose the clown will throw a plate to the 9th peg at the 9th second, if Cc stands on peg 9 at the 8th second and stands still for a second, or if Cc stand on peg 8 at the 8th second and jumps to peg 9, or if Cc stand on peg 10 at the 8th second and jumps to peg 9, he can catch the plate.
        There is a positive integer on each plate, indicating the bananas Cc can get if he catch that plate. Cc will know the way the clown throw the plates in advance. Now he wants to get as many bananas as possible.
    
    							

    input

     For each test case,the first line contains three integers n, m and t(1 <= n <= 100,1 <= m <= 100,0 <= t <= 100), indicating the number of the pegs, the number of the plates and the maximum number Cc can jump.The next m lines gives ai and bi each, which means the clown will throw a plate with number bi on it to peg ai at the ith second.
        Process to the end of file.
    							

    output

    For each test case, first print a line saying "Scenario #k", where k is the number of the test case.Then, print the maximum number Cc can get, one per line.Print a blank line after each test case, even after the last one.
    							

    sample_input

    4 4 2
    2 10
    3 15
    1 10
    1 8
    4 4 4
    2 10
    3 15
    1 10
    1 8
    2 2 1
    1 1
    2 1
    							

    sample_output

    Scenario #1
    28
    
    Scenario #2
    33
    
    Scenario #3
    2
    					

    没想到记忆化搜索效率比直接dp还要高


    #include <iostream>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    int n,m,t;
    
    int a[111][111];
    int f[111][111][111];
    
    int dfs(int jp,int time,int place)
    {
        if (f[jp][time][place]!=-1) return f[jp][time][place];
        int ret=0;
        if (time<m) ret=dfs(jp,time+1,place);
        if (place+1<=n&&jp>0&&time<m)
        {
            ret=max( ret, dfs(jp-1,time+1,place+1) );
        }
        if (place-1>=1&&jp>0&&time<m)
        {
            ret=max( ret, dfs(jp-1,time+1,place-1) );
        }
        f[jp][time][place]=ret+a[time][place];
        return f[jp][time][place];
    }
    
    int main()
    {
        int cnt=0;
        int maxt;
        while (cin>>n>>m>>t)
        {
            cnt++;
            maxt=0;
            memset(f,-1,sizeof(f));
            memset(a,0,sizeof(a));
            for (int i=1; i<=m; i++)
            {
                int x,y;
                cin>>x>>y;
                a[i][x]+=y;
            }
            int ans=dfs(t,0,1);
    
            cout<<"Scenario #"<<cnt<<endl;
            cout<<ans<<endl<<endl;
        }
        return 0;
    }
    



  • 相关阅读:
    向架构师进军--->如何编写软件架构文档
    让创意更有黏性!
    eaby技术架构变迁
    应用系统之间数据传输的几种方式
    基于 CAS 无锁实现的 Disruptor.NET 居然慢于 BlockingCollection,是真的吗?
    调整数据库表结构,搞定 WordPress 数据库查询缓慢问题
    dynamic-css 动态 CSS 库,使得你可以借助 MVVM 模式动态生成和更新 css,从 js 事件和 css 选择器的苦海中脱离出来
    ASP.NET Framework 重写后的 .NET 异常报错界面(异常堆栈和溯源一目了然)
    Orchard Core 中运行带程序上下文的单元测试
    Angular 2 前端 http 传输 model 对象及其外键的问题
  • 原文地址:https://www.cnblogs.com/cyendra/p/3038470.html
Copyright © 2011-2022 走看看