zoukankan      html  css  js  c++  java
  • UVa 1330 City Game 最大子矩阵

    Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems � he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

    Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

    Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

    Input 

    The first line of the input file contains an integer K � determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
    R � reserved unit
    F � free unit
    In the end of each area description there is a separating line.

    Output 

    For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

    Sample Input 

    2
    5 6
    R F F F F F
    F F F F F F
    R R R F F F
    F F F F F F
    F F F F F F
    
    5 5
    R R R R R
    R R R R R
    R R R R R
    R R R R R
    R R R R R
    

    Sample Output 

    45
    0
    -------------

    扫描线法求最大子矩阵

    -------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    const int maxn=1111;
    
    int mat[maxn][maxn];
    int n,m;
    
    //返回矩形的最大面积,障碍物代号为c
    int cat(int c)
    {
        int h[maxn],l[maxn],r[maxn];
        int lo,ro;
        int ans=0;
        for (int j=1;j<=m;j++)
        {
            h[j]=0;
            l[j]=1;
            r[j]=m;
        }
        for (int i=1;i<=n;i++)
        {
            lo=0;ro=m+1;
            for (int j=1;j<=m;j++)
            {
                if (mat[i][j]==c){ h[j]=0;l[j]=1;lo=j; }
                else
                {
                    h[j]++;
                    l[j]=max(l[j],lo+1);
                }
            }
            for (int j=m;j>=1;j--)
            {
                if (mat[i][j]==c){ r[j]=m;ro=j; }
                else
                {
                    r[j]=min(r[j],ro-1);
                    ans=max(ans,h[j]*(r[j]-l[j]+1));
                }
            }
        }
        return ans;
    }
    
    int main()
    {
        int T;
        cin>>T;
        while (T--)
        {
            cin>>n>>m;
            for (int i=1;i<=n;i++)
            {
                for (int j=1;j<=m;j++)
                {
                    char c;
                    cin>>c;
                    if (c=='F') mat[i][j]=0;
                    if (c=='R') mat[i][j]=1;
                }
            }
            cout<<cat(1)*3<<endl;
        }
        return 0;
    }
    






  • 相关阅读:
    第九届蓝桥杯JavaA组省赛真题
    Qt的IDE开发环境(KDevelop,MonKey Studio,QDevlop,Dev-cpp,Cobras,Edyuk)
    Eclipse+Qt开发环境设置(Linux和Win)
    Visual Studio 2005安装qt-win-commercial-src-4.3.1,并设置环境变量
    在VC6.0中编译头文件时产生moc文件
    Qt配置信息设置(QSettings在不同平台下的使用路径)
    应对业务需求变化?
    开发环境准备:Ruby on Rails开发环境配置
    VS2013中Python学习环境搭建
    JQUERY 插件开发——MENU(导航菜单)
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226297.html
Copyright © 2011-2022 走看看