zoukankan      html  css  js  c++  java
  • UVa 437 The Tower of Babylon LIS



     The Tower of Babylon 

    Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

    The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

    Input and Output

    The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

    Input is terminated by a value of zero (0) for n.

    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

    Sample Input

    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0

    Sample Output

    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342
    ----------------------

    LIS的变形

    ---------------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    struct SCV{
        int x;
        int y;
        int high;
    }a[1111];
    
    int f[1111111];
    
    bool cmp(SCV a,SCV b)
    {
        if (a.x==b.x) return a.y<b.y;
        return a.x<b.x;
    }
    int n,m;
    
    int main()
    {
        int cnt=1;
        int sum=0;
        int ans;
        while (~scanf("%d",&n))
        {
            if (n==0) break;
            memset(f,0,sizeof(f));
            memset(a,0,sizeof(a));
            m=0;
            sum=0;
            ans=0;
            for (int i=1;i<=n;i++)
            {
                int x,y,z;
                scanf("%d%d%d",&x,&y,&z);
                sum+=x+y+z;
                a[m].x=x;
                a[m].y=y;
                a[m].high=z;
                if (a[m].x<=a[m].y) swap(a[m].x,a[m].y);
                m++;
                a[m].x=x;
                a[m].y=z;
                a[m].high=y;
                if (a[m].x<=a[m].y) swap(a[m].x,a[m].y);
                m++;
                a[m].x=y;
                a[m].y=z;
                a[m].high=x;
                if (a[m].x<=a[m].y) swap(a[m].x,a[m].y);
                m++;
            }
            sort(a,a+m,cmp);
            for (int i=0;i<m;i++)
            {
                f[i]=a[i].high;
                for (int j=0;j<i;j++)
                {
                    if (a[i].x>a[j].x&&a[i].y>a[j].y&&f[j]+a[i].high>f[i])
                    {
                        f[i]=f[j]+a[i].high;
                    }
                }
                if (f[i]>ans) ans=f[i];
            }
            printf("Case %d: maximum height = %d\n",cnt++,ans);
        }
        return 0;
    }
    






     The Tower of Babylon 

    Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

    The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

    Input and Output

    The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

    Input is terminated by a value of zero (0) for n.

    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

    Sample Input

    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0

    Sample Output

    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342
  • 相关阅读:
    Sokect简单入门(1)TCP协议一
    Tomcat内存溢出 解决方法
    服务器配置 ssl 证书,Nginx配置
    优秀的博客文章记录
    SpringBoot实现优雅的关机
    关于 redis 的 数据类型 和 内存模型
    微信, qq 支付宝 等相关开发 资源 记录
    设计模式 之 单列设计模式
    Swagger
    MQ服务器奔溃解决过程
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226329.html
Copyright © 2011-2022 走看看