zoukankan      html  css  js  c++  java
  • UVa 562 Dividing coins 背包



      Dividing coins 

    It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


    Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


    That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


    Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

    Input 

    A line with the number of problems n, followed by n times:
    • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
    • a line with m numbers separated by one space, each number indicates the value of a coin.

    Output 

    The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

    Sample Input 

    2
    3
    2 3 5
    4
    1 2 4 6
    

    Sample Output 

    0
    1
    

    --------------------------

    orz 做水题好爽

    ---------------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    int f[111111];
    int a[111];
    int n;
    
    int main()
    {
        int T;
        int sum;
        scanf("%d",&T);
        while (T--)
        {
            memset(f,0,sizeof(f));
            sum=0;
            scanf("%d",&n);
            for (int i=1;i<=n;i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
            }
            f[0]=1;
            for (int i=1;i<=n;i++)
            {
                for (int j=sum/2-a[i];j>=0;j--)
                {
                    if (f[j]) f[j+a[i]]=1;
                }
            }
            int a,b;
            for (int i=sum/2;i>=0;i--)
            {
                if (f[i])
                {
                    a=i;
                    break;
                }
            }
            b=sum-a;
            int ans;
            if (a>b) ans=a-b;
            else ans=b-a;
            printf("%d\n",ans);
        }
        return 0;
    }
    









      Dividing coins 

    It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


    Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


    That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


    Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

    Input 

    A line with the number of problems n, followed by n times:
    • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
    • a line with m numbers separated by one space, each number indicates the value of a coin.

    Output 

    The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

    Sample Input 

    2
    3
    2 3 5
    4
    1 2 4 6
    

    Sample Output 

    0
    1
    

  • 相关阅读:
    20145221 《Java程序设计》第五周学习总结
    Atom插件安装
    Atom使用心得
    20145221 《Java程序设计》第四周学习总结
    20145221 《Java程序设计》第三周学习总结
    20145221 《Java程序设计》第二周学习总结
    20145221 《Java程序设计》第一周学习总结
    调查问卷
    《Java程序设计》第四章-认识对象
    在WEB-INF目录下的web.xml文件
  • 原文地址:https://www.cnblogs.com/cyendra/p/3226333.html
Copyright © 2011-2022 走看看