zoukankan      html  css  js  c++  java
  • IPv6实验 6PE

    6PE, a similar technology that is used to transport IPv6 traffic across an existing IPv4+MPLS core without touching your core equipment (P routers).

    The primary reason for this solution is as of this writing LDP does not support IPv6 prefixes. You can not create a fully functional label switched core using IPv6.  This requires making use of an existing IPv4 label switched core in order to distribute IPv6 labels properly. 6PE uses MP-BGP to distribute labels for IPv6 prefixes since LDP doesn’t currently support it.

    We will be using the same network for this solution as we did for the 6VPE example:


    R1===========================

    ip cef
    ipv6 unicast-routing
    ipv6 cef

    interface Loopback0
     no ip address
     ipv6 address 2000::1/128
    !
    interface e0/0
     no ip address
    no  shutdown
    !
    interface e0/0.12
    en do 12
     no ip address
     ipv6 address 2012::1/64
    !
    ipv6 route ::/0 2012::2
    !

    R2=========================================


    hostname R2
    ip cef
    ipv6 unicast-routing
    ipv6 cef

    mpls label protocol ldp
    mpls lab ran 2000 2999

    interface Loopback0
     ip address 2.2.2.2 255.255.255.255

    interface e0/0
     no ip address
    no  shutdown
    !
    interface e0/0.23
    en do 23
     ip address  23.1.1.2 255.255.255.0
     mpls ip
    !
    interface e0/0.12
    en do 12
     no ip address
     ipv6 address 2012::2/64
    !
    router ospf 100
     router-id 2.2.2.2
     log-adjacency-changes
     network 2.2.2.2 0.0.0.0 area 0
     network 23.1.1.2 0.0.0.0 area 0
    !
    router bgp 100
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 4.4.4.4 remote-as 100
     neighbor 4.4.4.4 update-source Loopback0
     !
     !
     address-family ipv6
      redistribute connected
      redistribute static
      no synchronization
      neighbor 4.4.4.4 activate
      neighbor 4.4.4.4 send-label
     exit-address-family
    !
    !
    ipv6 route 2000::1/128 2012::1
    !
    mpls ldp router-id Loopback0
    !


    R3=====================================

    ip cef
    no ipv6 cef
    !
    !
    mpls label protocol ldp
    mpls lab ra 3000 3999
    !
    !
    interface Loopback0
     ip address 3.3.3.3 255.255.255.255
    !
    interface e0/0
     no ip address
    no  shutdown
    !
    interface e0/0.23
    en do 23
     ip address 23.1.1.3 255.255.255.0
     mpls ip
    !
    interface e0/0.34
    en do 34
     ip address 34.1.1.3 255.255.255.0
     mpls ip
    !
    router ospf 100
     router-id 3.3.3.3
     log-adjacency-changes
     network 3.3.3.3 0.0.0.0 area 0
     network 23.1.1.3 0.0.0.0 area 0
     network 34.1.1.3 0.0.0.0 area 0

    mpls ldp router-id Loopback0


    R4===================================

    ip cef
    ipv6 unicast-routing
    ipv6 cef
    !
    !
    mpls label protocol ldp
    mpls lab r 4000 4999

    !
    interface Loopback0
     ip address 4.4.4.4 255.255.255.255
    !
    interface e0/0
     no ip address
    no  shutdown
     
    !
    interface e0/0.34
    en do 34
     ip address 34.1.1.4 255.255.255.0
     mpls ip
    !
    interface e0/0.45
    en do 45
     no ip address
     ipv6 address 2045::4/64
    !
    router ospf 100
     router-id 4.4.4.4
     log-adjacency-changes
     network 4.4.4.4 0.0.0.0 area 0
     network 34.1.1.4 0.0.0.0 area 0
    !
    router bgp 100
     no bgp default ipv4-unicast
     bgp log-neighbor-changes
     neighbor 2.2.2.2 remote-as 100
     neighbor 2.2.2.2 update-source Loopback0
     !
     address-family ipv4
      no synchronization
      no auto-summary
     exit-address-family
     !
     address-family ipv6
      redistribute connected
      redistribute static
      no synchronization
      neighbor 2.2.2.2 activate
      neighbor 2.2.2.2 send-label
     exit-address-family

    ipv6 route 2000::5/128 2045::5
    !
    mpls ldp router-id Loopback0

    R5=================================================


    ip cef

    ipv6 unicast-routing
    ipv6 cef

    !
    interface Loopback0
     no ip address
     ipv6 address 2000::5/128
    !
    interface e0/0
     no ip address
    no  shutdown
    !
    interface e0/0.45
    en do 45
     no ip address
     ipv6 address 2045::5/64
    !

    ipv6 route ::/0 2045::4
    !

  • 相关阅读:
    Makefile与shell脚本区别
    Linux fdisk命令参数及用法详解---Linux磁盘分区管理命令fdisk
    李洪强iOS开发之XMPP
    李洪强iOS开发之宏定义方法来初始化一个单例对象
    李洪强iOS开发之拓展篇—UIDynamic(简单介绍)
    李洪强iOS开发之【零基础学习iOS开发】【02-C语言】07-基本数据类型
    李洪强iOS开发之OC[018]对象和方法之间的关系
    李洪强漫谈iOS开发[C语言-011]
    李洪强iOS开发之静态库
    李洪强iOS开发之【零基础学习iOS开发】【02-C语言】06-变量与内存
  • 原文地址:https://www.cnblogs.com/cyrusxx/p/12824141.html
Copyright © 2011-2022 走看看