zoukankan      html  css  js  c++  java
  • poj-1426 Find The Multiple 搜索

    Find The Multiple
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 36135 Accepted: 15096 Special Judge
    Description


    Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
    Input


    The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
    Output


    For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
    Sample Input


    2
    6
    19
    0
    Sample Output


    10
    100100100100100100
    111111111111111111

    Source

    #include<map>
    #include<queue>
    #include<math.h>
    #include<vector>
    #include<string>
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    #define inf 0x3f3f3f
    #define ll long long
    #define maxn 100005
    using namespace std;
    int main()
    {
        int n;
        while(~scanf("%d",&n)&&n)
        {
            queue<ll>q;
            q.push(1);
            while(!q.empty())
            {
                ll m=q.front();
                q.pop();
                if(m%n==0)
                {
                    cout<<m<<endl;
                    break;
                }
                q.push(m*10);
                q.push(m*10+1);
            }
        }
    }




  • 相关阅读:
    Leetcode(337)-打家劫舍III
    Leetcode(213)-打家劫舍II
    Leetcode(198)-打家劫舍
    Leetcode(32)-最长有效括号
    计数排序
    智能指针
    C++中的explicit
    Leetcode(878)-第 N 个神奇数字
    Leetcode(877)-石子游戏
    C++的memset
  • 原文地址:https://www.cnblogs.com/da-mei/p/9053280.html
Copyright © 2011-2022 走看看