zoukankan      html  css  js  c++  java
  • 杭电1058

    Humble Numbers

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13689    Accepted Submission(s): 5956


    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

    Write a program to find and print the nth element in this sequence
     

    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
     

    Output
    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
     

    Sample Input
    1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
     

    Sample Output
    The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

    代码如下:

    #include <iostream>
    #include <algorithm>
    using namespace  std;
    #define  N 5842
    int values[N + 1] ;
    
    inline int minValue(int n1, int n2, int n3, int n4)
    {
    	return min(min(n1, n2), min(n3, n4)) ;
    }
    
    int main(int argc, char ** argv)
    {
    	memset(values, 0, ( N + 1 ) * sizeof(int)) ;
    	values[1] = 1 ;
    	int p1, p2, p3, p4 ;
    	p1 = p2 = p3 = p4 = 1 ;
    	
    	for (int i = 2; i <= N; ++ i)
    	{
    		values[i] = minValue(values[p1] * 2, values[p2] * 3, values[p3] * 5, values[p4] * 7) ;
    		if (values[p1] * 2 == values[i]) p1 ++ ;
    		if (values[p2] * 3 == values[i]) p2 ++ ;
    		if (values[p3] * 5 == values[i]) p3 ++ ;
    		if (values[p4] * 7 == values[i]) p4 ++ ;
    	}
    
    	int inValue ;
    	while(cin >> inValue && inValue != 0)
    	{
    		if (inValue % 100 == 11 || inValue % 100 == 12 || inValue % 100 == 13)
    			cout << "The "<< inValue << "th humble number is " <<values[inValue]<< "." << endl;
    		else	
    			if (inValue % 10 == 1)
    				cout << "The "<< inValue << "st humble number is " <<values[inValue]<< "." << endl;
    			else
    				if (inValue % 10 == 2)
    					cout << "The "<< inValue << "nd humble number is " <<values[inValue]<< "." << endl;
    				else
    					if (inValue % 10 == 3)
    						cout << "The "<< inValue << "rd humble number is " <<values[inValue]<< "." << endl;
    					else
    						cout << "The "<< inValue << "th humble number is " <<values[inValue]<< "." << endl;
    	}
    	return 0 ;
    }



  • 相关阅读:
    [K/3Cloud] 首页增加一个自定义页签及页面内容
    [K/3Cloud]DBServiceHelper.ExecuteDataSet(this.Context, sql)) 返回数据问题
    [K/3Cloud] 表单python脚本使用QueryService的做法
    [K/3Cloud]有关单据显示行数限制和数据导出的建议
    [K/3Cloud]实现双击列表行后显示具体的某个单据明细。
    [K/3Cloud]K3Cloud的移动审批方面
    [K/3Cloud]K3Cloud的移动审批方面
    [K/3Cloud]关于数据库sa密码更改,管理中心登录不上的问题。
    游戏编程最前沿....
    marmalade android 5.0 JNI 调用失败的解决方案
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405190.html
Copyright © 2011-2022 走看看