zoukankan      html  css  js  c++  java
  • 杭电1013


    Digital Roots

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 30319    Accepted Submission(s): 9309


    Problem Description
    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
     

    Input
    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
     

    Output
    For each integer in the input, output its digital root on a separate line of the output.
     

    Sample Input
    24 39 0
     

    Sample Output
    6 3


    //杭电1013,注意测试数据可能非常大,所以这里现实按照一个字符串进行读入
    #include <iostream>
    #include <cstring>
    using namespace std;
    
    int main(int argc, char **argv)
    {
        string str;
        while(cin >> str && str != "0")
        {
            int num = 0;
            
            for (int i =0; i < str.length(); ++ i)
                num += str[i] - '0';
            
            while (num >= 10) 
            {
                int temp = num;
                num = temp/10 + temp%10;
            }
            cout << num << endl;
        }
            return 0;
    }
    


  • 相关阅读:
    ASP.NET MVC 编程参考
    IDEA+Gradle相关资料
    【树莓派】Linux应用相关:自动删除n天前日志
    【树莓派】制作树莓派最小镜像:img裁剪瘦身
    【树莓派】树莓派下WiFi断线自动重连
    【树莓派】树莓派远程监控
    【树莓派】服务配置相关
    【树莓派】Linux自动配置IP
    Jmeter相关
    Linux集群监控工具简介:Ganglia和Nagios
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405219.html
Copyright © 2011-2022 走看看