zoukankan      html  css  js  c++  java
  • B

    You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
    Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

    Input

    The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
    The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

    Output

    For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

    Sample Input

    1 0
    
    2 3
    1 2 37
    2 1 17
    1 2 68
    
    3 7
    1 2 19
    2 3 11
    3 1 7
    1 3 5
    2 3 89
    3 1 91
    1 2 32
    
    5 7
    1 2 5
    2 3 7
    2 4 8
    4 5 11
    3 5 10
    1 5 6
    4 2 12
    
    0

    Sample Output

    0
    17
    16
    26

    之前一直是用的vector+sort,结果这次用数组就翻车了,找了好久的错终于发现了:
    Sorts the elements in the range [first,last) into ascending order.
    #include <iostream>
    #include <vector>
    #include <algorithm>
    #include <string>
    #include <set>
    #include <queue>
    #include <map>
    #include <sstream>
    #include <cstdio>
    #include <cstring>
    #include <numeric>
    #include <cmath>
    #include <iomanip>
    #include <deque>
    #include <bitset>
    //#include <unordered_set>
    //#include <unordered_map>
    //#include <bits/stdc++.h>
    //#include <xfunctional>
    #define ll              long long
    #define PII             pair<int, int>
    #define rep(i,a,b)      for(int  i=a;i<=b;i++)
    #define dec(i,a,b)      for(int  i=a;i>=b;i--)
    #define pb              push_back
    #define mk              make_pair
    using namespace std;
    int dir1[6][2] = { { 0,1 } ,{ 0,-1 },{ 1,0 },{ -1,0 },{ 1,1 },{ -1,1 } };
    int dir2[6][2] = { { 0,1 } ,{ 0,-1 },{ 1,0 },{ -1,0 },{ 1,-1 },{ -1,-1 } };
    const long long INF = 0x7f7f7f7f7f7f7f7f;
    const int inf = 0x3f3f3f3f;
    const double pi = 3.14159265358979;
    const int mod = 1e9 + 7;
    const int N = 10000;
    //if(x<0 || x>=r || y<0 || y>=c)
    
    inline ll read()
    {
        ll x = 0; bool f = true; char c = getchar();
        while (c < '0' || c > '9') { if (c == '-') f = false; c = getchar(); }
        while (c >= '0' && c <= '9') x = (x << 1) + (x << 3) + (c ^ 48), c = getchar();
        return f ? x : -x;
    }
    
    struct Edge
    {
        int s, t, w;
    };
    
    Edge e[N];
    int n, m, sets[N];
    bool cmp(Edge a, Edge b)
    {
        return a.w < b.w;
    }
    int find(int x)
    {
        if (x == sets[x])
            return x;
        int rt = find(sets[x]);
        sets[x] = rt;
        return sets[x];
    }
    bool Union(int x, int y)
    {
        int fx = find(x);
        int fy = find(y);
        if (fx == fy)
            return 0;
        sets[fx] = fy;
        return 1;
    }
    void kruskal()
    {
        int i, sum = 0;
        for (i = 1; i <= m; i++)
        {
            if (Union(e[i].s, e[i].t))
            {
                sum += e[i].w;
            }
        }
        cout << sum << endl;
    }
    int main()
    {
        while (cin >> n, n)
        {
            for (int i = 1; i <= n; i++)
            {
                sets[i] = i;
            }
            cin >> m;
            rep(i, 1, m)
            {
                cin >> e[i].s >> e[i].t >> e[i].w;
            }
            if (m >= 1)
            {
                sort(e + 1, e + m+1, cmp);//就是这个位置
                kruskal();
            }
            else
            {
                cout << 0 << endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    Python循环语句
    Python判断语句
    MySQL的基本操作汇总
    Python函数、类
    Python字典、集合
    Python列表、元组
    python数据类型--数字、字符串
    Python基础认识
    搭建Python独立虚拟环境
    Python包管理工具
  • 原文地址:https://www.cnblogs.com/dealer/p/12738329.html
Copyright © 2011-2022 走看看