zoukankan      html  css  js  c++  java
  • AtCoder Grand Contest 012 A

    Time limit : 2sec / Memory limit : 256MB

    Score : 300 points

    Problem Statement

    There are 3N participants in AtCoder Group Contest. The strength of the i-th participant is represented by an integer ai. They will form N teams, each consisting of three participants. No participant may belong to multiple teams.

    The strength of a team is defined as the second largest strength among its members. For example, a team of participants of strength 152 has a strength 2, and a team of three participants of strength 323 has a strength 3.

    Find the maximum possible sum of the strengths of N teams.

    Constraints

    • 1≤N≤105
    • 1≤ai≤109
    • ai are integers.

    Input

    Input is given from Standard Input in the following format:

    N
    a1 a2  a3N
    

    Output

    Print the answer.


    Sample Input 1

    Copy
    2
    5 2 8 5 1 5
    

    Sample Output 1

    Copy
    10
    

    The following is one formation of teams that maximizes the sum of the strengths of teams:

    • Team 1: consists of the first, fourth and fifth participants.
    • Team 2: consists of the second, third and sixth participants.

    Sample Input 2

    Copy
    10
    1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000
    

    Sample Output 2

    Copy
    10000000000
    

    The sum of the strengths can be quite large.


    ****************************************************************************************************************************************************

    题意:给你3N个数,要你组成N只team,每一只team3人 :D

    每一只team的值为3人的中间值。求出每一只对的总值。

    解题思路:先sort一下。可以得到 a1, a2, a3 ~~~~ aN aN+1 ~~~~ a2N a2N+1 ~~~~~a3N;

    要求和最大, 所以中间那个要最大,a1, a3N, a3N-1 组成一组

    很容易就可以知道贪心的策略了。

    ****************************************************************************************************************************************************

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    typedef long long LL;
    const int maxn = 300000+10;
    int a[maxn];
    int main()
    {
        ios::sync_with_stdio(0);
        int N;
        cin >> N;
        for(int i=0;i<3*N;i++)  cin >> a[i];
        sort(a, a+3*N);
        LL ans = 0;
        int j=3*N - 2;
        for(int i=1;i<=N;i++)
        {
            ans += a[j];
            j-=2;
        }
        cout << ans << endl;
        return 0;
    }



  • 相关阅读:
    javaweb学习总结二十六(response对象的用法二 下载文件)
    javaweb学习总结二十五(response对象的用法一)
    线程池的使用
    javaweb学习总结二十四(servlet经常用到的对象)
    javaweb学习总结二十三(servlet开发之线程安全问题)
    创建与删除索引
    Oracle中exists与in的区别
    win7安装IIS及将网站发布到IIS上
    C# toolstrip 上添加DateTimePicker Control控件
    用java实现zip压缩
  • 原文地址:https://www.cnblogs.com/denghaiquan/p/6666085.html
Copyright © 2011-2022 走看看