zoukankan      html  css  js  c++  java
  • poj 1849 Two(最长链)

    Two
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 1394   Accepted: 705

    Description

    The city consists of intersections and streets that connect them. 

    Heavy snow covered the city so the mayor Milan gave to the winter-service a list of streets that have to be cleaned of snow. These streets are chosen such that the number of streets is as small as possible but still every two intersections to be connected i.e. between every two intersections there will be exactly one path. The winter service consists of two snow plovers and two drivers, Mirko and Slavko, and their starting position is on one of the intersections. 

    The snow plover burns one liter of fuel per meter (even if it is driving through a street that has already been cleared of snow) and it has to clean all streets from the list in such order so the total fuel spent is minimal. When all the streets are cleared of snow, the snow plovers are parked on the last intersection they visited. Mirko and Slavko don’t have to finish their plowing on the same intersection. 

    Write a program that calculates the total amount of fuel that the snow plovers will spend. 

    Input

    The first line of the input contains two integers: N and S, 1 <= N <= 100000, 1 <= S <= N. N is the total number of intersections; S is ordinal number of the snow plovers starting intersection. Intersections are marked with numbers 1...N. 

    Each of the next N-1 lines contains three integers: A, B and C, meaning that intersections A and B are directly connected by a street and that street's length is C meters, 1 <= C <= 1000. 

    Output

    Write to the output the minimal amount of fuel needed to clean all streets.

    Sample Input

    5 2
    1 2 1
    2 3 2
    3 4 2
    4 5 1
    

    Sample Output

    6

    Source

     
    题意
    给出一棵树和根节点
    有两个人从根节点出发遍历整棵树求最小路径
     
    根据观察可以得出答案为 所有路径长度和*2-最长链
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #define maxn 100010
    using namespace std;
    int n,root,topt,ans,mx;
    int first[maxn];
    struct edge
    {
        int to;
        int val;
        int next;
    }e[maxn*2];
    void add(int x,int y,int z)
    {
        topt++;
        e[topt].to=y;
        e[topt].val=z;
        e[topt].next=first[x];
        first[x]=topt;
    }
    int dfs(int now,int from)
    {
        int maxx=0,maxt=0;
        for(int i=first[now];i;i=e[i].next)
        {
            int to=e[i].to;
            if(to==from)continue;
            int ha=e[i].val+dfs(to,now);
            if(ha>maxx)maxt=maxx,maxx=ha;
            else if(ha>maxt)maxt=ha;
        }
        mx=max(mx,maxx+maxt);
        return maxx;
    }
    int main()
    {
        scanf("%d%d",&n,&root);
        for(int i=1;i<n;i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);add(y,x,z);
            ans+=z*2;
        }
        dfs(root,root);
        printf("%d",ans-mx);
        return 0;
    } 
     
  • 相关阅读:
    贪心策略---不重叠的区间个数
    贪心策略---分配饼干
    双指针---最长子序列
    双指针---回文字符串
    双指针---反转字符串中的元音字符
    双指针---两数平方和
    双指针---有序数组的TWO SUM
    排序---小结
    排序---桶排序
    变量的解构赋值
  • 原文地址:https://www.cnblogs.com/dingmenghao/p/6001686.html
Copyright © 2011-2022 走看看