zoukankan      html  css  js  c++  java
  • HDOJ1159 Common Subsequence

    Common Subsequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12381    Accepted Submission(s): 5083


    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
     
    Sample Input
    abcfbc abfcab programming contest abcd mnp
     
    Sample Output
    4 2 0
    //最长公共子序列
    #include<iostream>
    #include<string>
    
    using namespace std;
    
    int Max(int i,int j)
    {
    	return i>j?i:j;
    }
    
    int LCSlength(string s1,string s2)
    {
    	int i,j;
    	int len1=s1.size();
    	int len2=s2.size();
    	int **a=new int *[len1+1];
    	for(i=0;i<=len1;++i)
    		a[i]=new int[len2+1];
    
    	for(i=0;i<=len1;i++)//注意动态数组不能用memset(a,0,sizeof(a))初始化  
            for(j=0;j<=len2;j++)  
                a[i][j] =0; 
    	for(i=1;i<=len1;++i)
    		for(j=1;j<=len2;++j)
    			if(s1[i-1]==s2[j-1])
    				a[i][j]=a[i-1][j-1]+1;
    			else
    				a[i][j]=Max(a[i-1][j],a[i][j-1]);
    	return a[len1][len2]; 
    }
    
    int main()
    {
    	string s1,s2;
    	while(cin>>s1>>s2)
    	{
    		
    		cout<<LCSlength(s1,s2)<<endl;
    	}
    	return 0;
    }
    
    功不成,身已退
  • 相关阅读:
    数据仓库_Linux(3)
    2.1(构造序对)
    要修改一万个位置的jdk版本
    8个球7个一样重的,有一个偏重,一个天平,如何两次找出偏重的小球
    玄学
    异常:java.lang.NoClassDefFoundError: javax/servlet/jsp/jstl/core/LoopTag
    提高输入效率
    fan
    idea
    打印整数的补码
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2552916.html
Copyright © 2011-2022 走看看