zoukankan      html  css  js  c++  java
  • poj2080 Calendar

    Calendar
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 8936   Accepted: 3354

    Description

    A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
    According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
    Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

    Input

    The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
    You may assume that the resulting date won’t be after the year 9999.

    Output

    For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

    Sample Input

    1730
    1740
    1750
    1751
    -1

    Sample Output

    2004-09-26 Sunday
    2004-10-06 Wednesday
    2004-10-16 Saturday
    2004-10-17 Sunday
    
    /*  
       功能Function Description:	   poj-2080
       开发环境Environment:            DEV C++ 4.9.9.1
       技术特点Technique:
       版本Version:
       作者Author:		           可笑痴狂
       日期Date:                      20120726
       notes:
            星期几很容易求,只要对7求模就知道,不过2000年1月1日是星期六,
    		星期几的字符数组第一个要注意。至于年月日,就是用昨天数减去每一年的天数,减多少年year就是多少,
    		month也一样,最后天数要加1.    
    */
    
    /*
    //代码一:(wrong answer)----不知道错在哪了
    #include<stdio.h>
    int table[12]={31,28,31,30,31,30,31,31,30,31,30,31};
    int year,day,month;
    int Is_leapyear(int n)
    {
    	if(n%400==0||n%4==0&&n%100)
    		return 1;
    	return 0;
    }
    
    void print(int n)
    {
    	printf("%d-%02d-%02d ",year,month,day);
    	switch (n)
    	{
    		case 0:
    			printf("Saturday\n");
    			break;
    		case 1:
    			printf("Sunday\n");
    			break;
    		case 2:
    			printf("Monday\n");
    			break;
    		case 3:
    			printf("Tuesday\n");
    			break;
    		case 4:
    			printf("Wednesday\n");
    			break;
    		case 5:
    			printf("Thursday\n");
    			break;
    		case 6:
    			printf("Friday\n");
    			break;
    	}
    }
    
    int main()
    {
    	int n,sum,i,t;
    	while(scanf("%d",&n))
    	{
    		if(n==-1)
    			break;
    		t=n%7;
    		table[1]=28;
    		++n;                        //把初始年份的第一天补上,即把2000-1-1这一天加上,而且经计算,2000-1-1为星期六
    		year=2000;
    		for(i=2000;;++i)
    		{
    			if(Is_leapyear(i)&&n>=366)
    				n-=366;
    			else if(n>=365)
    				n-=365;
    			else
    				break;
    			++year;
    		}
    		month=1;
    		sum=31;
    		if(Is_leapyear(year))
    			table[1]=29;
    		while(sum<n)
    			sum+=table[month++];
    		day=table[month-1]-(sum-n);
    		print(t);
    	}
    	return 0;
    }
    */
    
    //代码二:(AC)
    #include <stdio.h>
    #include<string.h>
    #include<math.h>
    
    char week[7][10]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
    int year[2]={365,366};
    int month[2][12]={31,28,31,30,31,30,31,31,30,31,30,31,31,29,31,30,31,30,31,31,30,31,30,31};
    int type(int m)
    {
    	if(m%4!=0||(m%100==0&&m%400!=0))
    		return 0;
    	else return 1; 
    }
    int main()
    {
    	int days,dayofweek;
    	int i=0,j=0;
    	while(scanf("%d",&days)!=EOF&&days!=-1)
    	{
    		dayofweek=days%7;
    		for(i=2000;days>=year[type(i)];i++)
    			days-=year[type(i)];
    		for(j=0;days>=month[type(i)][j];j++)
    			days-=month[type(i)][j];
    		printf("%d-%02d-%02d %s\n",i,j+1,days+1,week[dayofweek]);
    	}
    	return 0;
    }
    
    功不成,身已退
  • 相关阅读:
    mysql 主从配置
    doGet和doPost的区别
    我的第一个MVC项目
    c3p0xml配置详解
    c3p0连接数据库
    java加载资源文件
    Windows上部署Python
    Windows上部署Python
    NagiosQL安装
    Nagios Windows客户端NSClient++ 0.4.x安装配置
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2610485.html
Copyright © 2011-2022 走看看