zoukankan      html  css  js  c++  java
  • BestCoder Round 59 (HDOJ 5500) Reorder the Books

    Problem Description

    dxy has a collection of a series of books called “The Stories of SDOI”,There are n(n≤19) books in this series.Every book has a number from 1 to n.

    dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

    One day Evensgn visited dxy’s home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about “Little E&Little Q”. While losing himself in the story,he disrupted the order of the books.

    Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

    Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book “The Stories of SDOI 9: The Story of Little E” as a gift.

    Input

    There are several testcases.

    There is an positive integer T(T≤30) in the first line standing for the number of testcases.

    For each testcase, there is an positive integer n in the first line standing for the number of books in this series.

    Followed n positive integers separated by space standing for the order of the disordered books,the ith integer stands for the ith book’s number(from top to bottom).

    Hint:

    For the first testcase:Moving in the order of book3,book2,book1 ,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4),and this is the best way to reorder the books.
    For the second testcase:It’s already ordered so there is no operation needed.

    Output

    For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

    Sample Input

    2
    4
    4 1 2 3
    5
    1 2 3 4 5

    Sample Output

    3
    0

    Code

    #include <iostream>
    using namespace std;
    int main()
    {
        int T; cin >> T;
        int book[20];
        while (T--)
        {
            int n; cin >> n;
            int index, number = n;
            for (int i = 0; i < n; i++)
            {
                cin >> book[i];
                if (book[i] == n) index = i;
            }
            for (int i = index; i >= 0; i--)
            {
                if (book[i] == number) number--;
            }
            cout << number << endl;
        }
    
        return 0;
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    【洛谷】1852:[国家集训队]跳跳棋【LCA】【倍增?】
    【POJ】1835:宇航员【模拟】【三维行走】
    【BZOJ】3195: [Jxoi2012]奇怪的道路【状压/奇偶性】【思路】
    【10.24校内测试】【欧拉路径(有向+无向)】【双向链表/树状数组/线段树】
    【POJ】1840:Eqs【哈希表】
    【洛谷】4317:花神的数论题【数位DP】
    【POJ】1486:Sorting Slides【二分图关键边判定】
    算法模板
    Redis源码阅读一:简单动态字符串SDS
    总结下c/c++的一些调试经验
  • 原文地址:https://www.cnblogs.com/doodle777/p/4873432.html
Copyright © 2011-2022 走看看