zoukankan      html  css  js  c++  java
  • 1038 Recover the Smallest Number (30 分)

    Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

    Input Specification:

    Each input file contains one test case. Each case gives a positive integer N (≤) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

    Sample Input:

    5 32 321 3214 0229 87
     

    Sample Output:

    22932132143287
     
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100010;
    string s[maxn];
    bool cmp(string a,string b){
        return a+b<b+a;//理解:按照满足这种规则的方式进行排序
    }
    int main(){
        int n;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>s[i];
        }
        sort(s,s+n,cmp);
        string st;
        for(int i=0;i<n;i++){
            st+=s[i];
        }
        while(st.size()!=0&&st[0]=='0'){
            st.erase(st.begin());
        }
        if(st.size()==0){
            cout<<0<<endl;
        }
        else{
            cout<<st<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Servlet生命周期
    DAO 开发模式的几个类
    Iterator用法
    mysql相似于oracle的to_char() to_date()方法
    Java Web页面跳转
    JSP 连接MySQL 5.1
    采用DOM进行表格的修改操作
    使用css让XML文件按照HTML的风格显示出来
    正则表达式Regular Expression
    什么是“堆”,"栈","堆栈","队列",它们的区别
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14488962.html
Copyright © 2011-2022 走看看