zoukankan      html  css  js  c++  java
  • 1089 Insert or Merge (25 分) 归并排序

    According to Wikipedia:

    Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

    Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

    Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:

    10
    3 1 2 8 7 5 9 4 6 0
    1 2 3 7 8 5 9 4 6 0
     

    Sample Output 1:

    Insertion Sort
    1 2 3 5 7 8 9 4 6 0
     

    Sample Input 2:

    10
    3 1 2 8 7 5 9 4 0 6
    1 3 2 8 5 7 4 9 0 6
     

    Sample Output 2:

    Merge Sort
    1 2 3 8 4 5 7 9 0 6
     
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100005;
    const int N=111;
    
    int main(){
        int n,a[100],b[100],i,j;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        for(int i=0;i<n;i++){
            cin>>b[i];
        }
        for(i=0;i<n-1&&b[i]<=b[i+1];i++);
        for(j=i+1;a[j]==b[j]&&j<n;j++);
        if(j==n){
            cout<<"Insertion Sort"<<endl;
            sort(a,a+i+2);
        }else{
            cout<<"Merge Sort"<<endl;
            int k=1,flag=1;
            while(flag){
                flag=0;
                for(i=0;i<n;i++){
                    if(a[i]!=b[i]){
                        flag=1;
                    }
                }
                k=k*2;
                for(i=0;i<n/k;i++){
                    sort(a+i*k,a+(i+1)*k);
                }
                sort(a+n/k*k,a+n);
            }
        }
        for(j=0;j<n;j++){
            if(j!=0)
            {
                printf(" ");
            }
            printf("%d",a[j]);
        }
        return 0;
    }
  • 相关阅读:
    Excel操作基本方法 服务器端不用安装Office工具
    使用IrisSkin2给软件"换肤"
    手机进行GPRS连接的代码(C#.NET开发)
    C# DataGridView 倒出word
    win2003优化大全 (转载)
    c# Invoke和BeginInvoke 区别
    关于sqlite3使用top的一些规则总结
    C#拷贝文件和复制文件夹实例代码 C#拷贝文件
    c# FileSystemWatcherc# FileSystemWatcher控件的使用方法控件的使用方法
    所见即所得富文本编辑器实现原理 转
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14519718.html
Copyright © 2011-2022 走看看