zoukankan      html  css  js  c++  java
  • 1006 Sign In and Sign Out (25 分)

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
     

    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
     

    Sample Output:

    SC3021234 CS301133
    思路:用结构体存储信息,找出最早和最晚的时间,这里可以直接用string存储时间,方便比较
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10010;
    typedef struct students{
        string ID;
        string sin;
        string sout;
    }stu;
    int main(){
        int n;
        stu st[maxn];
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>st[i].ID;
            cin>>st[i].sin;
            cin>>st[i].sout;
        }
        string earSin,lastSout;
        string earId,lastId;
        earSin=st[0].sin;
        earId=st[0].ID;
        lastSout=st[0].sout;
        lastId=st[0].ID;
        for(int i=0;i<n;i++){
            if(st[i].sin<earSin){
                earSin=st[i].sin;
                earId=st[i].ID;
            }
            if(st[i].sout>lastSout){
                lastSout=st[i].sout;
                lastId=st[i].ID;
            }
        }
        cout<<earId<<" "<<lastId<<endl;
        return 0;
    }


  • 相关阅读:
    Tomcat应用中post方式传参数长度限制
    关于动态生成data组件
    H5 App开发用WeX5垃圾 试用一周,我果断放弃了wex5
    windowDialog销毁页面的问题
    WeX5之xid相关API
    ADB工具 获取ROOT权限及复制文件方法
    Android中使用am命令实现在命令行启动程序详解
    SQLite加密的方法(c#)
    C# Winform中如何让PictureBox的背景透明
    Android Camera API2中采用CameraMetadata用于从APP到HAL的参数交互
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14905171.html
Copyright © 2011-2022 走看看