zoukankan      html  css  js  c++  java
  • CCF 201403-3 命令行选项 (STL模拟)

    问题描述
      请你写一个命令行分析程序,用以分析给定的命 令行里包含哪些选项。每个命令行由若干个字符串组成,它们之间恰好由一个空格分隔。这些字符串中的第一个为该命令行工具的名字,由小写字母组成,你的程序 不用对它进行处理。在工具名字之后可能会包含若干选项,然后可能会包含一 些不是选项的参数。
      选项有两类:带参数的选项和不带参数的选项。一个合法的无参数选项的形式是一个减号后面跟单个小写字母,如"-a" 或"-b"。而带参数选项则由两个由空格分隔的字符串构成,前者的格式要求与无参数选项相同,后者则是该选项的参数,是由小写字母,数字和减号组成的非空 字符串。
      该命令行工具的作者提供给你一个格式字符串以指定他的命令行工具需要接受哪些选项。这个字符串由若干小写字母和冒号组成,其中的每个小写字母表示一个 该程序接受的选项。如果该小写字母后面紧跟了一个冒号,它就表示一个带参数的选项,否则则为不带参数的选项。例如, "ab:m:" 表示该程序接受三种选项,即"-a"(不带参数),"-b"(带参数), 以及"-m"(带参数)。
      命令行工具的作者准备了若干条命令行用以测试你的程序。对于每个命令行,你的工具应当一直向后分析。当你的工具遇到某个字符串既不是合法的选项,又不是某个合法选项的参数时,分析就停止。命令行剩余的未分析部分不构成该命令的选项,因此你的程序应当忽略它们。
    输入格式
      输入的第一行是一个格式字符串,它至少包含一个字符,且长度不超过 52。格式字符串只包含小写字母和冒号,保证每个小写字母至多出现一次,不会有两个相邻的冒号,也不会以冒号开头。
      输入的第二行是一个正整数 N(1 ≤ N ≤ 20),表示你需要处理的命令行的个数。
      接下来有 N 行,每行是一个待处理的命令行,它包括不超过 256 个字符。该命令行一定是若干个由单个空格分隔的字符串构成,每个字符串里只包含小写字母,数字和减号。
    输出格式
       输出有 N 行。其中第 i 行以"Case i:" 开始,然后应当有恰好一个空格,然后应当按照字母升序输出该命令行中用到的所有选项的名称,对于带参数的选项,在输出它的名称之后还要输出它的参数。如果 一个选项在命令行中出现了多次,只输出一次。如果一个带参数的选项在命令行中出 现了多次,只输出最后一次出现时所带的参数。
    样例输入
    albw:x
    4
    ls -a -l -a documents -b
    ls
    ls -w 10 -x -w 15
    ls -a -b -c -d -e -l
    样例输出
    Case 1: -a -l
    Case 2:
    Case 3: -w 15 -x
    Case 4: -a -b
     
    析:用map来模拟,然后不断更新答案即可,还可以用流来简化运算。
     
    代码如下:
    #pragma comment(linker, "/STACK:1024000000,1024000000")
    #include <cstdio>
    #include <string>
    #include <cstdlib>
    #include <cmath>
    #include <iostream>
    #include <cstring>
    #include <set>
    #include <queue>
    #include <algorithm>
    #include <vector>
    #include <map>
    #include <cctype>
    #include <cmath>
    #include <stack>
    #include <list>
    #include <sstream>
    #define frer freopen("in.txt", "r", stdin)
    #define frew freopen("out.txt", "w", stdout)
    using namespace std;
    
    typedef long long LL;
    typedef pair<int, int> P;
    const int INF = 0x3f3f3f3f;
    const double inf = 0x3f3f3f3f3f3f;
    const double PI = acos(-1.0);
    const double eps = 1e-8;
    const int maxn = 1e3 + 5;
    const int mod = 1e9 + 7;
    const int dr[] = {-1, 1, 0, 0};
    const int dc[] = {0, 0, 1, -1};
    const char *de[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
    int n, m;
    const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    inline int Min(int a, int b){ return a < b ? a : b; }
    inline int Max(int a, int b){ return a > b ? a : b; }
    inline LL Min(LL a, LL b){ return a < b ? a : b; }
    inline LL Max(LL a, LL b){ return a > b ? a : b; }
    inline bool is_in(int r, int c){
        return r >= 0 && r < n && c >= 0 && c < m;
    }
    string s;
    map<string, string> ans;
    int a[30];
    
    int main(){
        while(cin >> s){
            bool ok = false;
            memset(a, 0, sizeof a);
            for(int i = 0; i < s.size(); ++i){
                if(s[i] == ':')  a[s[i-1]-'a'] = 2;
                else a[s[i]-'a'] = 1;
            }
    
            cin >> n;
            getchar();
            for(int kase = 1; kase <= n; ++kase){
                ans.clear();
                getline(cin, s);
                stringstream ss(s);
                bool ok = false;
                string t;
                int x = 0;
                while(ss >> s){
                    if(!x){ ++x; continue; }
    
                    if(s[0] != '-' && !ok)  break;
                    if(ok){  ans[t] = s;  ok = false; }
                    else if(s.size() > 1 && s[0] == '-' &&  a[s[1]-'a'] == 1)  ans[s] = "A";
                    else if(s.size() > 1 && s[0] == '-' &&  a[s[1]-'a'] == 2)  t = s, ok = true;
                    else break;
                }
                if(!ans.size())  printf("Case %d: ", kase);
                else printf("Case %d:", kase);
                for(map<string, string> :: iterator it = ans.begin(); it != ans.end(); ++it)
                    if(it->second == "A")  cout << " " << it->first;
                    else cout << " " << it->first << " " << it->second;
                cout << endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    华为P20 无法投屏到电视
    configuration error &ndash; unknown item &lsquo;umask&rsquo; (notify administrator)
    oracle不支持update from的语法
    SQL Server 中update的小计
    sqlplus连接oracle数据库--密码含特殊字符
    redhat 7.6安装oracle 11gR2遇到两个问题
    ORA-15032 ORA-15028
    ORA-07391 sftopen error unable to open text file
    ORA-01017 invalid username/password logon denied
    Oracle CRS/GI 进程介绍
  • 原文地址:https://www.cnblogs.com/dwtfukgv/p/5819187.html
Copyright © 2011-2022 走看看