zoukankan      html  css  js  c++  java
  • 【贪心】删数问题

    【贪心】删数问题

    题目描述

    输入一个高精度的正整数n(≤240位),去掉其中任意s个数字后,剩下的数字按原左右次序组成一个新的正整数。编程对给定的n和s,寻找一种方案,使得剩下的数字组成的新数最小。

    输入

    第1行:一个正整数n;
    第2行:s(s<n的位数).

    输出

    最后剩下的最小数。

    样例输入

    175438
    4
    

    样例输出

    13
    分析:结论是删去第一个递减的数,如果没有则删去最后一个数;
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cmath>
    #include <algorithm>
    #include <climits>
    #include <cstring>
    #include <string>
    #include <set>
    #include <map>
    #include <queue>
    #include <stack>
    #include <vector>
    #include <list>
    #include <ext/rope>
    #define rep(i,m,n) for(i=m;i<=n;i++)
    #define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
    #define vi vector<int>
    #define pii pair<int,int>
    #define mod 1000000007
    #define inf 0x3f3f3f3f
    #define pb push_back
    #define mp make_pair
    #define fi first
    #define se second
    #define ll long long
    #define pi acos(-1.0)
    const int maxn=5e3+10;
    const int dis[4][2]={{0,1},{-1,0},{0,-1},{1,0}};
    using namespace std;
    using namespace __gnu_cxx;
    ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
    ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
    int n,m,len;
    string ans;
    int main()
    {
        int i,j,k,t;
        cin>>ans>>n;
        while(n--)
        {
            len=ans.length();
            rep(i,0,len-2)if(ans[i]>ans[i+1])break;
            ans.erase(i,1);
        }
        len=ans.length();
        for(i=0;i<len&&ans[i]=='0';i++);
        if(i==len)puts("0");
        else cout<<ans.substr(i,len-i)<<endl;
        //system ("pause");
        return 0;
    }
  • 相关阅读:
    浏览器渲染原理
    前端日常工作性能优化条例
    前端的发展历程
    【YOLO-V1】You Only Look Once: Unified, Real-Time Object Detection
    ModuleNotFoundError: No module named 'keras_retinanet.utils.compute_overlap'
    python学习笔记:线性回归
    软件安装笔记5:navicat for mysql及其简单应用
    python学习笔记39:sklearn
    python学习笔记38:matplotlib
    python学习笔记37:pandas
  • 原文地址:https://www.cnblogs.com/dyzll/p/5697002.html
Copyright © 2011-2022 走看看