zoukankan      html  css  js  c++  java
  • 2016大连网络赛 Different GCD Subarray Query

    Different GCD Subarray Query

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

    Problem Description
    This is a simple problem. The teacher gives Bob a list of problems about GCD (Greatest Common Divisor). After studying some of them, Bob thinks that GCD is so interesting. One day, he comes up with a new problem about GCD. Easy as it looks, Bob cannot figure it out himself. Now he turns to you for help, and here is the problem:
      
      Given an array a of N positive integers a1,a2,aN1,aN; a subarray of a is defined as a continuous interval between a1 and aN. In other words, ai,ai+1,,aj1,aj is a subarray of a, for 1ijN. For a query in the form (L,R), tell the number of different GCDs contributed by all subarrays of the interval [L,R].
      
     
    Input
    There are several tests, process till the end of input.
      
      For each test, the first line consists of two integers N and Q, denoting the length of the array and the number of queries, respectively. N positive integers are listed in the second line, followed by Q lines each containing two integers L,R for a query.

    You can assume that
      
        1N,Q100000
        
       1ai1000000
     
    Output
    For each query, output the answer in one line.
     
    Sample Input
    5 3 1 3 4 6 9 3 5 2 5 1 5
     
    Sample Output
    6 6 6
     
    分析:对于每个点来说,向前的gcd很少,可以预处理出gcd出现的最后的左端点;
       然后离线查询右端点,每走到一个点,更新gcd出现的左端点,然后树状数组询问答案即可;
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cmath>
    #include <algorithm>
    #include <climits>
    #include <cstring>
    #include <string>
    #include <set>
    #include <map>
    #include <queue>
    #include <stack>
    #include <vector>
    #include <list>
    #define rep(i,m,n) for(i=m;i<=n;i++)
    #define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
    #define mod 1000000007
    #define inf 0x3f3f3f3f
    #define vi vector<int>
    #define pb push_back
    #define mp make_pair
    #define fi first
    #define se second
    #define ll long long
    #define pi acos(-1.0)
    #define pii pair<int,int>
    #define Lson L, mid, rt<<1
    #define Rson mid+1, R, rt<<1|1
    const int maxn=1e5+10;
    using namespace std;
    ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
    ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
    int n,m,k,t,a[maxn],c[maxn],pr[maxn*10],ans[maxn];
    vector<pii >b[maxn];
    vector<pii >q[maxn];
    void add(int x,int y)
    {
        for(int i=x;i<=n;i+=(i&(-i)))
            c[i]+=y;
    }
    int get(int x)
    {
        int ret=0;
        for(int i=x;i;i-=i&(-i))
            ret+=c[i];
        return ret;
    }
    void init()
    {
        for(int i=1;i<=n;i++)
        {
            int x=a[i],y=i;
            b[i].pb(mp(x,y));
            for(int j=0;j<b[i-1].size();j++)
            {
                int now=gcd(b[i-1][j].fi,a[i]),pos=b[i-1][j].se;
                if(now!=x)
                {
                    b[i].pb(mp(now,pos));
                    x=now;
                }
            }
        }
    }
    int main()
    {
        int i,j;
        while(~scanf("%d%d",&n,&m))
        {
            rep(i,1,n)scanf("%d",&a[i]),b[i].clear(),q[i].clear();
            memset(c,0,sizeof c);
            memset(pr,0,sizeof pr);
            init();
            rep(i,1,m)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                q[y].pb(mp(x,i));
            }
            rep(i,1,n)
            {
                for(j=0;j<b[i].size();j++)
                {
                    int x=b[i][j].fi,pos=b[i][j].se;
                    if(pr[x])add(pr[x],-1);
                    add(pos,1);
                    pr[x]=pos;
                }
                for(int j=0;j<q[i].size();j++)
                {
                    int x=q[i][j].fi,y=q[i][j].se;
                    ans[y]=get(i)-(x-1==0?0:get(x-1));
                }
            }
            rep(i,1,m)printf("%d\n",ans[i]);
        }
        //system("Pause");
        return 0;
    }
  • 相关阅读:
    10.RobotFramework: 获取当前时间戳
    9.接口自动化-自定义关键字、接口设计规范
    8.接口自动化-RequestLibrary库的介绍与示例讲解
    7.接口自动化-环境常用库搭建
    6.数据库操作(DatabaseLibrary)与常见问题
    5.远程服务器操作(SSHLibrary)
    概率密度与概率分布函数
    Linux安装包类型
    随机变量与随机过程
    hosts文件
  • 原文地址:https://www.cnblogs.com/dyzll/p/5860950.html
Copyright © 2011-2022 走看看