zoukankan      html  css  js  c++  java
  • HDU 4707 DFS

    Problem Description
    One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
     
    Input
    The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
     
    Output
    For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
     
    Sample Input
    1
    10 2
    0 1
    0 2
    0 3
    1 4
    1 5
    2 6
    3 7
    4 8
    6 9
     
    Sample Output
    2
     
    水题,DFS练手
    #include<set>
    #include<cstdio>
    #include<vector>
    #include<cstring>
    #include<iostream>
    using namespace std;
    
    set<int>donser;
    vector<int>d[100010];
    int r=0,num=0,lable=0,deep=0;
    void dfs(int i)
    {
        if(deep>=r||d[i].empty()){donser.insert(i);return;}
        while(d[i].size()>0)
        {
            deep++;
            donser.insert(i);
            lable=d[i].back();
            d[i].pop_back();
            dfs(lable);
            deep--;
        }
    }
    int main()
    {
        int a,n,b,T,x,y;
        scanf("%d",&T);
        for(a=1;a<=T;a++)
        {
            scanf("%d%d",&n,&r);
            for(b=1;b<n;b++)
            {
                scanf("%d%d",&x,&y);
                d[x].push_back(y);
            }
            dfs(0);
            cout<<n-donser.size()<<endl;
            r=num=lable=deep=0;
            donser.clear();
            memset(d,0,sizeof(d));
        }
        return 0;
    }
    View Code
  • 相关阅读:
    C# GetHashCode 部分冲突列表 数字字符串版本
    Amazon Dynamo DB
    SCTP 一句话介绍
    SystemTap 使用以及安装
    Windows Azure Service Disruption on Feb 29th
    发布ASP.NET MVC3网站
    SQLServer数据集合的交、并、差集运算
    DataTable的几个函数
    oracle创建表空间以及用户的语句
    asp.net mvc3及odp.net资料下载地址
  • 原文地址:https://www.cnblogs.com/dzzy/p/5059920.html
Copyright © 2011-2022 走看看