zoukankan      html  css  js  c++  java
  • HDU 3999 二叉排序树

     

    The order of a Tree

    Problem Description
    The shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
    1.  insert a key k to a empty tree, then the tree become a tree with
      only one node;
    2.  insert a key k to a nonempty tree, if k is less than the root ,insert
      it to the left sub-tree;else insert k to the right sub-tree.
      We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate                           the same tree.Two trees are the same if and only if they have the same shape.
     
    Input
    There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
     
    Output
    One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.
     
    Sample Input
    4
    1 3 4 2
     
    Sample Output
    1 3 2 4
     
    二叉排序树如何建立和遍历是关键。
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int ld[100010],rd[100010],a,num,root,i;
    void build(int root,int al)
    {
        if(al>root)
        {
            if(rd[root]==-1)
            {
                rd[root]=al;
                //cout<<"al:"<<al<<" r root:"<<root<<endl;
            }
            else build(rd[root],al);
        }
        else
        {
            if(ld[root]==-1)
            {
                ld[root]=al;
                //cout<<"al:"<<al<<" l root:"<<root<<endl;
            }
            else build(ld[root],al);
        }
    }
    
    void solve(int root)
    {
        if(ld[root]!=-1)
        {
            cout<<" "<<ld[root];
            solve(ld[root]);
        }
        if(rd[root]!=-1)
        {
            cout<<" "<<rd[root];
            solve(rd[root]);
        }
        else return;
    }
    
    int main()
    {
        while(~scanf("%d",&num))
        {
            memset(ld,-1,sizeof(ld));
            memset(rd,-1,sizeof(rd));
            for(i=1;i<=num;i++)
            {
                scanf("%d",&a);
                if(i==1){root=a;}
                else build(root,a);
            }
            cout<<root;
            solve(root);
            cout<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    VMware 中安装Centos
    go with go
    [APIO2012]派遣【左偏树】
    后缀自动机三·重复旋律6
    AC自动机(二次加强版)
    [HAOI2016]找相同字符【GSAM广义后缀自动机】
    吉司机线段树【学习笔记】
    [ZJOI2015]诸神眷顾的幻想乡【GSAM】
    广义后缀自动机(广义 SAM)【模板】
    Important Sisters【HDU-4694】【Dominator Tree】
  • 原文地址:https://www.cnblogs.com/dzzy/p/5071065.html
Copyright © 2011-2022 走看看