zoukankan      html  css  js  c++  java
  • Number Sequence(kmp算法)

    Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

    InputThe first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
    OutputFor each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
    Sample Input

    2
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 1 3
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 2 1

    Sample Output

    6
    -1

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<set>
    #include<vector>
    #include<stack>
    #include<queue>
    #include<algorithm>
    #include<cstdio>
    #include<algorithm>
    #include<functional>
    #include<sstream>
    using namespace std;
    const double g = 10.0, eps = 1e-9;
    const int N = 1000000 + 5, maxn = 10000 + 5, inf = 0x3f3f3f3f;
    
    int ext[N], str[maxn], ptr[N];
    void getnext(int slen)
    {
        ext[0] = -1;
        int k = -1;
        for (int i = 1; i <= slen - 1; i++)
        {
            while (k>-1 && str[k + 1] != str[i])k = ext[k];
            if (str[k + 1] == str[i])k++;
            ext[i] = k;
        }
    }
    int kmp(int plen, int slen)
    {
        int k = -1;
        for (int i = 0; i <= plen - 1; i++)
        {
            while (k>-1 && str[k + 1] != ptr[i])k = ext[k];
            if (str[k + 1] == ptr[i])k++;
            if (k == slen - 1)return i - slen + 2;
        }
        return -1;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        //   cout<<setiosflags(ios::fixed)<<setprecision(2);
        int t, n, m;
        cin >> t;
        while (t--) {
            cin >> n >> m;
            for (int i = 0; i<n; i++)cin >> ptr[i];
            for (int i = 0; i<m; i++)cin >> str[i];
            getnext(m);
            cout << kmp(n, m) << endl;
        }
        return 0;
    }
  • 相关阅读:
    Portal技术介绍
    DBlibrary 常用函数
    【转】如何让你的WinForm嵌入桌面
    【转】Windows快捷方式文件格式解析(中文)
    合理安排时间
    javascript脚本压缩工具JSEncoder实现
    【转及整理】C#管理快捷方式文件创建
    【转】房产崩盘路线图
    【转】关于个人知识管理(PKM)的一些基本概念
    Javascript代码压缩、加密算法的破解分析及工具实现
  • 原文地址:https://www.cnblogs.com/edych/p/7275947.html
Copyright © 2011-2022 走看看