zoukankan      html  css  js  c++  java
  • 路由器配置——基于区域的OSPF,MD5认证

    一、实验目的:掌握OSPF基于区域的MD5认证

    二、拓扑图:

    三、具体步骤配置

    (1)R1路由器配置

    Router>enable

    Router#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R1

    R1(config)#interface s0/0/0

    R1(config-if)#ip address 192.168.1.1 255.255.255.0

    R1(config-if)#clock rate 64000

    R1(config-if)#no shutdown

    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

    R1(config-if)#exit

    R1(config)#interface l0

    R1(config-if)#ip address 1.1.1.1 255.255.255.0

    R1(config-if)#no shutdown

    R1(config-if)#exit

    R1(config)#router ospf 1

    R1(config-router)#router-id 1.1.1.1

    R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

    R1(config-router)#network 1.1.1.0 0.0.0.255 area 0

    R1(config-router)#area 0 authentication message-digest

    R1(config-router)#interface s0/0/0

    R1(config-if)#ip ospf message-digest-key 1 md5 123

    R1(config-if)#end

    (2)R2路由器配置

    Router>enable

    Router#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R2

    R2(config)#interface s0/0/0

    R2(config-if)#ip address 192.168.1.2 255.255.255.0

    R2(config-if)#clock rate 64000

    This command applies only to DCE interfaces

    R2(config-if)#no shutdown

    R2(config-if)#exit

    R2(config)#interface l0 

    R2(config-if)#ip address 2.2.2.2 255.255.255.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

    R2(config)#router ospf 1

    R2(config-router)#router-id 2.2.2.2

    R2(config-router)#network 192.168.1.0 0.0.0.255 area 0

    R2(config-router)#network 2.2.2.0 0.0.0.255 area 0

    R2(config-router)#area 0 authentication message-digest

    R2(config-router)#interface s0/0/0

    R2(config-if)#ip ospf message-digest-key 1 md5 123

    R2(config-if)#end

    四、验证测试:

    (1)检查接口是否启用了MD5 认证,密钥是多少

    红色标记处表示接口启用了MD5 认证,密钥是1

    (2)检查区域0是否 采用MD5 认证

    红色标记处表明区域0采用MD5 认证

    (3)如果R1 区域0 启动MD5 认证,而R2 区域0 启动简单口令认证,则R2 上出现下面
    的信息:
    *Feb 10 11:08:13.075: OSPF: Rcv pkt from 192.168.12.1, Serial0/0/0 : Mismatch
    Authentication type. Input packet specified type 2, we use type 1
    (4)如果R1 和R2 的区域0 都启动MD5 认证,但是R2 的接口下没有配置key ID 和密
    码或密码错误,则R2 上出现下面的信息:
    *Feb 10 11:08:43.075: OSPF: Rcv pkt from 192.168.12.1, Serial0/0/0 : Mismatch
    Authentication Key - No message digest key 1 on interface

  • 相关阅读:
    ACM: SCU 4440 Rectangle
    ACM: NBUT 1646 Internet of Lights and Switches
    ACM: Long Live the Queen
    ACM: Racing Gems
    C++ 11 笔记 (一) : lambda
    cocos2d-x笔记2: 编译到安卓的步骤与注意事项
    C++笔记1: 单例模式。(一个简单的设计模式在C++中复杂出翔。。)
    Java笔记2 : 泛型的体现,及其上限、下限、通配符
    我终于忍不住喷一下某些书了,关于Java传引用的XX言论
    Java笔记1 : 在生产者消费者模式中,线程通信与共享数据,死锁问题与解决办法
  • 原文地址:https://www.cnblogs.com/evolve/p/9233414.html
Copyright © 2011-2022 走看看