zoukankan      html  css  js  c++  java
  • Big Chocolate

    Big Chocolate

    题目链接:http://acm.hust.edu.cn/vjudge/problem/visitOriginUrl.action?id=19127

    Big Chocolate

    Mohammad has recently visited Switzerland . As he loves his friends very much, he decided to buy some chocolate for them, but as this fine chocolate is very expensive(You know Mohammad is a little BIT stingy!), he could only afford buying one chocolate, albeit a very big one (part of it can be seen in figure 1) for all of them as a souvenir. Now, he wants to give each of his friends exactly one part of this chocolate and as he believes all human beings are equal (!), he wants to split it into equal parts.

    The chocolate is an rectangle constructed from  unit-sized squares. You can assume that Mohammad has also  friends waiting to receive their piece of chocolate.

    To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines that separate the squares). Then, he should do the same with each part separately until he reaches  unit size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the minimum number of cuts required to accomplish this task.

    Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares apart.

     

    Figure 1. Mohammad’s chocolate

     

    The Input

    The input consists of several test cases. In each line of input, there are two integers , the number of rows in the chocolate and , the number of columns in the chocolate. The input should be processed until end of file is encountered.

    The Output

    For each line of input, your program should produce one line of output containing an integer indicating the minimum number of cuts needed to split the entire chocolate into unit size pieces.

    Sample Input

    2 2

    1 1

    1 5

     

    Sample Output

    3

    0

    4

    题意:将一块M*N的巧克力切成单位大小的巧克力;求出削减所有的巧克力块所需的最小刀数的数量。

    分析:

    如果是正方形(M=N)不管如何切都是一样的,当是长方形时如M>N就先切M-1刀使它变成M块N*1的巧克力,

    再将这些巧克力切成单位大小的巧克力。

    #include<iostream>
     #include<cstdio>
      using namespace std;
      int main()
      {
      int n,m,cut;
      while(scanf("%d%d",&n,&m)!=EOF)
      {    cut=0;
     if(n>m)
     cut=n*(m-1)+n-1;
     else cut=m*(n-1)+m-1;
     cout<<cut<<endl;
    }
     return 0;
     }
    
  • 相关阅读:
    [转]字符串相似度算法(编辑距离算法 Levenshtein Distance)
    [转]Earth Mover's Distance (EMD)
    [转]相似度计算常用方法综述
    小和问题和逆序对问题
    递归的理解
    验证方法是否正确——对数器
    CSS的几个核心概念(复盘大纲~)
    CSS3过渡
    CSS经典布局
    CSS3边框和圆角
  • 原文地址:https://www.cnblogs.com/fenhong/p/4656207.html
Copyright © 2011-2022 走看看