zoukankan      html  css  js  c++  java
  • Common Subsequence LCS

    题目链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=87730#problem/F

    题目:

    Description

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

    Input

    The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

    Output

    For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

    Sample Input

    abcfbc         abfcab
    programming    contest 
    abcd           mnp

    Sample Output

    4
    2
    0

    分析:

     这个就是LCS的裸体。

    状态转移方程:
    
    
        若a[i] = b[j] dp[i][j] = dp[i-1][j-1] + 1
    
    
        若a[i] != b[j] dp[i][j] = max(dp[i-1][j],dp[i][j-1])
     
    #include<iostream>  
    #include<cstring> 
    #include<cstdio>
    using namespace std;  
    char a[1000],b[1000];
    int dp[1000][1000];
    int max(int a,int b)
    {
    if(a>b) return a;
    else return b;
    }
    int main()
    {
        int t,i,j;
        while(scanf("%s%s",a,b)!=EOF)
        {     
            memset(dp,0,sizeof(dp));
         int n=strlen(a);
         int m=strlen(b);
         for(i=1;i<=n;i++)
             for(j=1;j<=m;j++)
             {     
                 if(a[i-1]==b[j-1])
                      dp[i][j]=dp[i-1][j-1]+1;
                 else 
                     dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
             }
                 cout<<dp[n][m]<<endl;
        }
    
        return 0;
    }
     
  • 相关阅读:
    gateone DSM 8271
    手机
    epub- https://www.taoshudang.com/
    [outlook] [vba] Highlight text in body of incoming emails
    HDMI ARC功能详解及应用介绍
    蓝光播放机
    surfingkeys
    亿格瑞A5-hdmi故障了
    解决VS无法连接到已配置的开发web服务器或者部署在IIS上的web服务打不开的问题
    解决远程连接mysql很慢的方法
  • 原文地址:https://www.cnblogs.com/fenhong/p/4734833.html
Copyright © 2011-2022 走看看