zoukankan      html  css  js  c++  java
  • HDU

    Fliping game

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2129    Accepted Submission(s): 1427

    Problem Description
    Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x1, y1)-(n, m) (1 ≤ x1≤n, 1≤y1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x1≤x≤n, y1≤y≤m)). The only restriction is that the top-left corner (i.e. (x1, y1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.
     
    Input
    The first line of the date is an integer T, which is the number of the text cases.
    Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.
     
    Output
    For each case, output the winner’s name, either Alice or Bob.
     
    Sample Input
    2
    2 2
    1 1
    1 1
    3 3
    0 0 0
    0 0 0
    0 0 0
     
    Sample Output
    Alice
    Bob
     
     
    题意 
      A与B在玩一个游戏,规则如下,在一个n*m的方格中,每一个格子都可为1或为0,每个人都能选定一个点,将以这个点为左上角,(n,m)为右下角的矩形内每个格子的数值翻转(0变1,1变0),其中选定的点只能作1到0的翻转,无路可走的人则输(面对全为0的矩阵)。A先手。给出一个棋盘,问谁获胜?
     
    分析 
      这种题,第一眼感觉就是有某种规律或者必胜的局面。果不其然,当右下角的格子为1时,A获胜,反之,B获胜。因为不管谁操作,右下角的方格都是会翻转的。
     
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    #include<algorithm>
    #include<cstring>
    #include <queue>
    #include <vector>
    #include<bitset>
    using namespace std;
    typedef long long LL;
    const int maxn = 400;
    const int mod = 772002+233;
    typedef pair<int,int> pii;
    #define X first
    #define Y second
    #define pb push_back
    //#define mp make_pair
    #define ms(a,b) memset(a,b,sizeof(a))
    
    const int inf = 0x3f3f3f3f;
    
    int main(){
        int t;
        cin>>t;
        while(t--){
            int n,m;
            cin>>n>>m;
            int f=0;
            int x;
            for(int i=0;i<n;i++)
            for(int j=0;j<m;j++){
                scanf("%d",&x);
                if(i==n-1&&j==m-1&&x) f=1;
            }
            if(f) puts("Alice");
            else puts("Bob");
        }
    }
  • 相关阅读:
    jQuery 自执行函数
    IRelationalOperator空间关系接口简介
    9.2 空间拓扑运算[转]
    解决关于ArcGIS10.2服务手动启动的问题
    Multipart to single part feature
    Multipart polyline to single part lines
    VS2015 C#6.0 中的没有实现/支持的特性
    VS2015 C#6.0 中的那些新特性
    ArcGIS中各种合并要素(Union、Merge、Append、Dissolve)的异同点分析 转载
    FME2010 案例分析: 动态批量转换
  • 原文地址:https://www.cnblogs.com/fht-litost/p/8563652.html
Copyright © 2011-2022 走看看