zoukankan      html  css  js  c++  java
  • POJ 3267 The Cow Lexicon

    The Cow Lexicon
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 7909   Accepted: 3711

    Description

    Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

    The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

    Input

    Line 1: Two space-separated integers, respectively: W and L 
    Line 2: L characters (followed by a newline, of course): the received message 
    Lines 3..W+2: The cows' dictionary, one word per line

    Output

    Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

    Sample Input

    6 10
    browndcodw
    cow
    milk
    white
    black
    brown
    farmer

    Sample Output

    2

    题意:怎样删除最少的字母,可以使得字符串是以下列出来的字符串的连接。

    动态规划,这里是从前往后的DP方程。


    AC代码例如以下:



    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    
    int min(int a,int b)
    {
        return a<b?a:b;
    }
    
    int main()
    {
        int n,m;
        int i,j;
        char a[610],b[1005][1005];
        int dp[610];
        int la,lb;
        int x,y;
        while(cin>>n>>m)
        {
            cin>>a+1;
            for(i=0;i<n;i++)
                cin>>b[i]+1;
            dp[0]=0;
            for(i=1;i<=m;i++)
            {
                dp[i]=dp[i-1]+1;//假设无法匹配
                for(j=0;j<n;j++)
                {
                    lb=strlen(b[j]+1);
                    x=0;y=lb;
                    if(i>=lb&&a[i]==b[j][lb])
                    {
                        while(i-x>0)
                        {
                            if(a[i-x]==b[j][y])
                            {x++;y--;}
                            else x++;
                            if(!y)
                            {
                                dp[i]=min(dp[i],dp[i-x]+x-lb);
                                break;
                            }
                        }
                    }
    
                }
            }
            cout<<dp[m]<<endl;
        }
        return 0;
    }
    




  • 相关阅读:
    软件测试基本功之——概念篇
    bug描述注意点
    软件测试模型汇总-V模型,W模型,X模型,H模型
    软件测试分类(自动化测试暂不描述)
    黑盒测试用例设计方法&理论结合实际 -> 场景法
    前端学习(36)~js学习(十三):this
    前端学习(35)~js学习(十二):预编译
    前端学习(34)~js学习(十一):作用域和变量提升
    前端学习(33)~js学习(十):函数
    前端学习(32)~js学习(九):对象简介和对象的基本操作
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4075866.html
Copyright © 2011-2022 走看看