zoukankan      html  css  js  c++  java
  • HDU 1027 以数列

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4803    Accepted Submission(s): 2885


    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?


     

    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     

    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     

    Sample Input
    6 4 11 8
     

    Sample Output
    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

    非常经典的一条取数列问题,就是找到一个数列中第m大的数列。

    假设使用暴力法就须要O(n!)时间效率。使用特别的方法直接取出数列。那么时间效率就是O(n)了。

    方法就是使用m生成一个取数数列,依据取数数列直接取出d第m大的数,就能够了。

    要规范一下函数的接口。形成良好的编程习惯。


    网易叫我改投他们的运营,通知明天笔试。我突然间好像说,f you!

    你运营的能写出我这么美丽的代码吗?你运营的须要这么好的算法嘛?你运营的须要数十万行的代码经验吗?


    #include <stdio.h>
    #include <vector>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    #include <string>
    #include <limits.h>
    #include <stack>
    #include <queue>
    #include <set>
    #include <map>
    using namespace std;
    
    const int MAX_N = 1001;
    int arr[MAX_N], N, M, tbl[MAX_N], a2[MAX_N];
    
    bool genTbl(int tbl[], int n, int m)//n 位。 第m个
    {
    	--m;
    	if (m < 0) return false;
    	tbl[n-1] = 0;
    	for (int d = 2, i = n-2; i >= 0 ; d++, i--)
    	{
    		tbl[i] = m%d;
    		m /= d;
    	}
    	return true;
    }
    
    void eraseElement(int arr[], int i, int *n)
    {
    	(*n)--;
    	for (; i < *n; i++)
    	{
    		arr[i] = arr[i+1];
    	}
    }
    
    void getSequence(int res[], int arr[], int tbl[], int n)
    {
    	int i = 0;
    	int *p = arr;
    	while (n)
    	{
    		for ( ; n > 0 && tbl[i] == 0; n--, p++, i++)
    		{
    			res[i] = *p;
    		}
    		if (!n) return ;
    		res[i] = p[tbl[i]];
    		eraseElement(p, tbl[i], &n);
    		i++;
    	}
    }
    
    int main()
    {
    	while (~scanf("%d %d", &N, &M))
    	{
    		for (int i = 0; i < N; i++)
    		{
    			arr[i] = i+1;
    		}
    		genTbl(tbl, N, M);
    		getSequence(a2, arr, tbl, N);
    		printf("%d", a2[0]);
    		for (int i = 1; i < N; i++)
    		{
    			printf(" %d", a2[i]);
    		}
    		putchar('
    ');
    	}
    	return 0;
    }



    版权声明:笔者心脏靖,景空间地址:http://blog.csdn.net/kenden23/,可能不会在未经作者同意转载。

  • 相关阅读:
    12
    Kafka设计解析(二)- Kafka High Availability (上)
    Apache kafka 工作原理介绍
    Kafka设计解析(一)- Kafka背景及架构介绍
    【转载】MySQL之权限管理
    【转载】漫谈HADOOP HDFS BALANCER
    【转载】HDFS 上传文件不均衡和Balancer太慢的问题
    【转载】mysql binlog日志自动清理及手动删除
    【转】Typora极简教程
    更新Linux服务器时间
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4652316.html
Copyright © 2011-2022 走看看