zoukankan      html  css  js  c++  java
  • [POJ] 2823 Sliding Window

    Sliding Window
    Time Limit: 12000MS     Memory Limit: 65536K
    Total Submissions: 66136        Accepted: 18796
    Case Time Limit: 5000MS
    Description
    
    An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
    The array is [1 3 -1 -3 5 3 6 7], and k is 3.
    Window position Minimum value   Maximum value
    [1  3  -1] -3  5  3  6  7   -1  3
     1 [3  -1  -3] 5  3  6  7   -3  3
     1  3 [-1  -3  5] 3  6  7   -3  5
     1  3  -1 [-3  5  3] 6  7   -3  5
     1  3  -1  -3 [5  3  6] 7   3   6
     1  3  -1  -3  5 [3  6  7]  3   7
    Your task is to determine the maximum and minimum values in the sliding window at each position. 
    
    Input
    
    The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 
    Output
    
    There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 
    Sample Input
    
    8 3
    1 3 -1 -3 5 3 6 7
    Sample Output
    
    -1 -3 -3 -3 3 3
    3 3 5 5 6 7
    Source
    
    POJ Monthly--2006.04.28, Ikki

    单调队列,感觉理解深刻了。

    //Stay foolish,stay hungry,stay young,stay simple
    #include<iostream>
    
    using namespace std;
    
    const int MAXN=1000005;
    
    int q[MAXN],id[MAXN],head=1,tail;
    int a[MAXN];
    int n,k;
    
    int main(){
        cin.sync_with_stdio(false);
        cin>>n>>k;
        for(int i=1;i<=n;i++){
            cin>>a[i];
        }
        for(int i=1;i<=n;i++){
            int v=a[i];
            while(tail>=head&&q[tail]>v) tail--;
            q[++tail]=v;
            id[tail]=i;
            while(id[head]<=i-k) head++;
            if(i>=k) cout<<q[head]<<" ";
        }
        cout<<endl;
        tail=0;head=1;
        for(int i=1;i<=n;i++){
            int v=a[i];
            while(tail>=head&&q[tail]<v) tail--;
            q[++tail]=v;
            id[tail]=i;
            while(id[head]<=i-k) head++;
            if(i>=k) cout<<q[head]<<" ";
        }
        return 0;
    }
    

    本文来自博客园,作者:GhostCai,转载请注明原文链接:https://www.cnblogs.com/ghostcai/p/9247449.html

  • 相关阅读:
    Android Studio的project中两个build.gradle配置的区别
    build script和all projects作用和区别
    让overflow:auto页面滚动条出现时不跳动
    GreenDao设置数据版本
    Greendao 缓存问题
    js中文编码到C#后台解码
    content-type: application/json没有设置导致的500错误
    Android的Device File Explorer刷新文件
    adb server version (31) doesn't match this client (40); killing...
    Sqlserver远程过程调用失败
  • 原文地址:https://www.cnblogs.com/ghostcai/p/9247449.html
Copyright © 2011-2022 走看看