zoukankan      html  css  js  c++  java
  • poj2010(Moo University

    Description

    Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

    Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

    Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

    Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

    Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

    Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

    Input

    * Line 1: Three space-separated integers N, C, and F 

    * Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

    Output

    * Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

    Sample Input

    3 5 70
    30 25
    50 21
    20 20
    5 18
    35 30
    

    Sample Output

    35
    

    Hint

    Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 

    题意:给你 c头牛和每头牛的智商、花费,要你选择 n头牛使这 n头牛智商的中位数最大,前提是花费总和不能超过 f


    题解:先对每头牛的智商从小到大排序,然后枚举智商的中位数,对于某个中位数i,左边和右边各取花费最小的n/2头牛。怎么取呢?先用优先队列预处理每头牛左右两边n/2头牛花费最小值即可。


    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    
    const int maxn = 100010;
    
    priority_queue<int> p, q;
    int n, c, f;
    pair<int, int> cow[maxn];
    int l[maxn], r[maxn];
    
    int main()
    {
        cin >> n >> c >> f;
        for (int i = 0; i < c; ++i)
            scanf("%d%d", &cow[i].first, &cow[i].second);
        sort(cow, cow+c);
    
        //预处理以i为中位数时左边n/2头牛花费的最小值
        int s = 0;
        for (int i = 0; i < c; ++i)
        {
            if (p.size() == n / 2)
                l[i] = s;
            p.push(cow[i].second);
            s += cow[i].second;
            if (p.size() > n / 2)
            {
                s -= p.top();
                p.pop();
            }
        }
    
        //预处理以i为中位数时右边n/2头牛花费的最小值
        s = 0;
        for (int i = c-1; i >= 0; --i)
        {
            if (q.size() == n / 2)
                r[i] = s;
            q.push(cow[i].second);
            s += cow[i].second;
            if (q.size() > n / 2)
            {
                s -= q.top();
                q.pop();
            }
        }
    
        //从大到小枚举中位数,满足题意就退出
        for (int i = c-(n+1)/2; i >= n/2; --i)
        {
            int sum = cow[i].second + l[i] + r[i];
            if (sum <= f)
            {
                cout << cow[i].first << endl;
                return 0;
            }
        }
        cout << "-1" << endl;
        return 0;
    }
    


  • 相关阅读:
    bat入门--第一个bat文件
    Egret的Shape
    Less Time, More profit 最大权闭合子图(最大流最小割)
    Mayor's posters POJ
    Stars POJ
    Snacks
    有趣的数列 卡特兰数
    Devu and Flowers lucas定理+容斥原理
    整数分解为2的幂 数学
    易碎的鸟蛋 概率DP
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203957.html
Copyright © 2011-2022 走看看