zoukankan      html  css  js  c++  java
  • poj3666(Making the Grade)

    Description

    A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

    You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

    AB1| + | AB2| + ... + | AN - BN |

    Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

    Input

    * Line 1: A single integer: N
    * Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

    Output

    * Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

    Sample Input

    7
    1
    3
    2
    4
    5
    3
    9
    

    Sample Output

    3

    题意:给定一个正整数序列a[1...n],要求你改变每一个数变成c[1...n],使得改变后的序列非严格单调,改变的代价为sigma(abs(a[i]-c[i])),求代价最小值。

    题解:显然c[i]必定为a[1...n]中的某个值,且由于a过大,所以离散化,将a数组保存在b数组中并排序。设dp[i][j]为第i个数改变为b[j]时代价最小值,则dp[i][j]=min(dp[i-1][k])+abs(a[i]-b[j]),其中k<=j,即b[k]<b[j]。这题还可以使用滚动数组来优化空间。

    #include <iostream>
    #include <sstream>
    #include <fstream>
    #include <string>
    #include <map>
    #include <vector>
    #include <list>
    #include <set>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <algorithm>
    #include <functional>
    #include <iomanip>
    #include <limits>
    #include <new>
    #include <utility>
    #include <iterator>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <cctype>
    #include <cmath>
    #include <ctime>
    using namespace std;
    
    int n, a[2010], b[2010], dp[2010];
    
    int main()
    {
        cin >> n;
        for (int i = 0; i < n; ++i)
        {
            scanf("%d", &a[i]);
            b[i] = a[i];
        }
        sort(b, b+n);
        for (int i = 0; i < n; ++i)
            dp[i] = abs(a[0]-b[i]);
        for (int i = 1; i < n; ++i)
        {
            int tmp_min = dp[0];
            for (int j = 0; j < n; ++j)
            {
                tmp_min = min(tmp_min, dp[j]);
                dp[j] = tmp_min + abs(a[i]-b[j]);
            }
        }
        cout << *min_element(dp, dp+n) << endl;
        return 0;
    }


  • 相关阅读:
    Struts2 拦截器(interceptor) 与 模型驱动3中传值方式
    Struts2 OGNL表达式
    ThreadLocal 是什么
    struts2的值栈(重点) 值栈是一个存储数据的内存结构 本质是一个接口 它的实现类OgnlValueStack
    Struts2 普通的java类 (Action)与Servlet通信 主要对象那个ServletActionContext 与 ActionContext对象来获取servlet中request对象和response对象
    struts2是多例的
    Django中一个项目里怎么使用两个数据库
    MYSQL中的锁
    详解Linux中文乱码问题终极解决方法
    Docker-compose up时报错:
  • 原文地址:https://www.cnblogs.com/godweiyang/p/12203971.html
Copyright © 2011-2022 走看看