zoukankan      html  css  js  c++  java
  • Nasty Hacks

    Nasty Hacks

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 30   Accepted Submission(s) : 8
    Problem Description

    You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

     
    Input

    The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: −106r, e ≤ 106 and 0 ≤ c ≤ 106.

     
    Output

    Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.

     
    Sample Input
    3
    0 100 70
    100 130 30
    -100 -70 40
     
    Sample Output
    advertise
    does not matter
    do not advertise
     
     
    c code:

    #include<stdio.h>
    int main()
    {
             int n,a,b,c,i;
            while(scanf("%d",&n)!=EOF)
            {
                 for(i=0;i<n;i++)
                 {
                        scanf("%d%d%d",&a,&b,&c);
                        if(a<(b-c))
                            printf("advertise ");
                       else if(a>(b-c))
                            printf("do not advertise ");
                      else
                            printf("does not matter ");
                  }
            }
        return 0;
    }

    c++   code:

    #include<iostream>
    using namespace std;
    int main()
    {
           int n,a,b,c;
           cin>>n;
           while(n--)
           {
                 cin>>a>>b>>c;
                 if(a<(b-c))
                          cout<<"advertise"<<endl;
                 else if(a>(b-c))
                         cout<<"do not advertise"<<endl;
                 else
                         cout<<"does not matter"<<endl;
            }
       return 0;
    }

     
     
     
     
     
     
     
     
     
     
     
  • 相关阅读:
    《编程珠玑,字字珠玑》读书笔记完结篇——AVL树
    中国人,不能自卑,要自强于世界民族之林
    做饭方法
    创建一个强名称密钥文件+ 如何在 Visual C# .NET 中将程序集安装到全局程序集缓存中
    .Net 题目
    页面传值的另一种办法
    成功的12条黄金法则
    English学习资料大全
    .NET中的Serialization
    页面标签使用 实现定位
  • 原文地址:https://www.cnblogs.com/gongpulin/p/3922213.html
Copyright © 2011-2022 走看看