zoukankan      html  css  js  c++  java
  • 1027. Colors in Mars (20)

    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output

    For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

    Sample Input

    15 43 71
    

    Sample Output

    #123456

    题目大意:就是将十进制数换成13进制数,如果有字母就用大写的A、B、C来表示;

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int main(){
    	int n,m;
    	string str[14]={"0","1","2","3","4","5","6","7","8","9","A","B","C"};
    	int i,j,k;
    	for(i=0;i<3;i++){
    		scanf("%d",&n);
    		m=n%13;
    		n=n/13;
    		if(n==0){
    			if(i==0){
    				cout<<"#";
    			}
    			cout<<"0"<<str[m];
    		}
    		else{
    			if(i==0){
    				cout<<"#";
    			}
    			cout<<str[n]<<str[m];
    		}
    	}
    	cout<<endl;
    	return 0;
    } 
    

      



  • 相关阅读:
    好吧,左小波出山了——ie8兼容indexOf问题
    jmeter负载机运行/添加压力机/分布式
    jmeter操作数据库
    Charles手机抓包设置&无法打开火狐网页设置
    python学习-Day1-接口测试
    动态SQL
    MyBatis缓存
    正则表达式
    MyBatis配置文件的配置说明
    几种数据源的配置
  • 原文地址:https://www.cnblogs.com/grglym/p/7675497.html
Copyright © 2011-2022 走看看