zoukankan      html  css  js  c++  java
  • 1058 选择题 (20 分)

    批改多选题是比较麻烦的事情,本题就请你写个程序帮助老师批改多选题,并且指出哪道题错的人最多。

    输入格式:

    输入在第一行给出两个正整数 N(≤ 1000)和 M(≤ 100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

    输出格式:

    按照输入的顺序给出每个学生的得分,每个分数占一行。注意判题时只有选择全部正确才能得到该题的分数。最后一行输出错得最多的题目的错误次数和编号(题目按照输入的顺序从 1 开始编号)。如果有并列,则按编号递增顺序输出。数字间用空格分隔,行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple

    输入样例:

    3 4 
    3 4 2 a c
    2 5 1 b
    5 3 2 b c
    1 5 4 a b d e
    (2 a c) (2 b d) (2 a c) (3 a b e)
    (2 a c) (1 b) (2 a b) (4 a b d e)
    (2 b d) (1 e) (2 b c) (4 a b c d)
    

    输出样例:

    3
    6
    5
    2 2 3 4

    Code:

    #include<iostream>
    #include<set>
    #include<string>
    #include<algorithm>
    
    using namespace std;
    
    struct que {
        int id;
        int sorce;
        int choice_num;
        int correct_num;
        int false_num = 0;
        set<char> correct_choice;
    } q[105];
    
    bool cmp(que a, que b) {
        if (a.false_num == b.false_num) return a.id < b.id;
        else a.false_num > b.false_num;
    }
    
    int main() {
        int n, m;
        cin >> n >> m;
    
        for (int i = 0; i < m; ++i) {
            int x, y, z;
            cin >> x >> y >> z;
            q[i].sorce = x, q[i].choice_num = y;
            q[i].correct_num = z, q[i].id = i+1;
            char c;
            for (int j = 0; j < z; ++j) {
                cin >> c;
                q[i].correct_choice.insert(c);
            }
            getchar();
        }
    
        string str;
        for (int i = 0; i < n; ++i) {
            int ans = 0;
            getline(cin, str);
            int s = 0, e = 0;
            string sub_str;
            int idx = 0;
            while (str.find("(", s) != string::npos) {
                s = str.find("(", s);
                e = str.find(")", e);
                sub_str = str.substr(s+1, e-s-1);
                s++, e++;
                int num = sub_str[0] - '0';
                int p = 0, correct_choice_num = 0;
                for (int j = 0; j < num; ++j) {
                    p = sub_str.find(" ", p);
                    char c = sub_str[++p];
                    if (q[idx].correct_choice.count(c)) { 
                        correct_choice_num++;
                    }
                }
                if (correct_choice_num == q[idx].correct_num && num == q[idx].correct_num) 
                    ans += q[idx].sorce;
                else 
                    q[idx].false_num++;
                idx++;
            }
            cout << ans << endl;
        }
    
        sort(q, q+m, cmp);
    
        cout << q[0].false_num << " " << q[0].id;
        for (int i = 1; i < m; ++i) 
            if (q[i].false_num == q[0].false_num)
                cout << " " << q[i].id; 
    
        cout << endl;
    
        return 0;
    }
    

      

    20分得了14,两组数据没过。

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    POJ 2503 Babelfish
    POJ 2528 Mayor's posters
    203C Photographer
    190A Vasya and the Bus
    POJ 3630 Trie树 TLE
    ThinkPHP验证码的使用
    mysql_fetch_row、mysql_fetch_array、mysql_fetch_assoc、mysql_fetch_object
    ThinkPHP模版布局方式
    Windows 下使用Git管理Github项目
    浅析mysql、mysqli、PDO
  • 原文地址:https://www.cnblogs.com/h-hkai/p/10459165.html
Copyright © 2011-2022 走看看